WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Google is complaining about Sitemap.xml (3 posts)

  1. bschollnick
    Member
    Posted 3 years ago #

    I am using Yoast's WordPress SEO (v0.21) and it seems that periodically the Sitemap is not being built correctly....

    I have not yet been able to find any specific triggering actions, but I have the sitemap being rebuilt after every posting... As well as images being added to the sitemap.

    I have captured some of the XML files if that would assist in the debugging....

    Also, if I trigger a manual rebuild, it seems to take forever (several minutes) to build... Assuming WordPress SEO finishes, sometimes it never seems to finish...

    In comparison the previous Sitemap utility only usually took 15-30 seconds...

    Yoast, is there an email address I can send the XML files to?

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    yes there is, joost @ my domain :)

  3. bschollnick
    Member
    Posted 3 years ago #

    It appears that 0.23 fixes the issue with 0.22 not outputing a valid XML file...
    But it appears that we have a re-occurrence of 0.21's occassional coruption of the XML file...

    I sent you another XML file via Email...

    I am not sure that Apple Mail is preserving the Date/time stamp, so...

    The XML file is a timestamp of 10:01 pm, and the xml.gz is 8:11pm.

    It appears that the XML file was regenerated at 10pm, which I believe I had made a minor edit of a page... before I crashed for the night...

    Could it be that the XML file is not being updated correctly after a edit of a existing page? And I suspect that the Gzipped version is untouched? Possibly WordPress-Seo died before it could re-gzip the bad xml file?

    I am making an guess here.... And haven't looked at the source, so I'm probably wrong...

    Also, where can we set the path for the sitemap.xml in wordpress-seo? I just realized that I had mapped it to the \sitemap.xml in the google xml sitemap, but wordpress-seo is working off the wordpress subdirectory... (eg, \wordpress\sitemap.xml)

    I don't see any place to set the location of the XML files...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic