WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Gallery Images Still Not Being Indexed in Sitemaps (8 posts)

  1. Neustop Designs
    Member
    Posted 2 years ago #

    It seems that the main problem with images in the XML sitemaps has been fixed, however if images are posted as a regular wordpress gallery they are still being ignored for some reason. I have a site that is extremely image-heavy and it is having trouble ranking even though they pictures have been correctly named and tagged for SEO.

    I believe part of the problem is because the images are not showing up in the XML sitemaps. I've tried other sitemap generators and they have the exact same issue. Is there any way to get a standard wordpress image gallery to show up in the XML site map or am I going to have to manually code 100+ images into the site?

    You can see the site in question here: http://www.bgawning.com/awnings-for-business/

    And here is the sitemap: http://www.bgawning.com/page-sitemap.xml

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Could I run some tests on your site? Happy to try and work it into the xml sitemaps :)

  3. Neustop Designs
    Member
    Posted 2 years ago #

    Sure! Where would you like me to send the login information?

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    joost @ my domain please!

  5. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Done, check your sitemap, will release this with 1.1.2 early next week :)

  6. Neustop Designs
    Member
    Posted 2 years ago #

    Thanks Joost! Awesome plugin by the way, dunno what I'd do with out it.

  7. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    My pleasure, 1.1.2 is coming later today, found another bug that really needs patching.

  8. gooma2
    Member
    Posted 2 years ago #

    Hey Joost,

    I'm having the same issue with the gallery images (Nextgen Gallery) where it just shows a number of images and not the individual ones. I saw that whatever magic you did with neustop's showed all the images and alts.

    Just seeing if there's something I can do to adjust for this too.

    Thanks so much!

    http://bestmoviesevernews.com/page-sitemap.xml

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic