WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Focus keyword not recognized in URL if more than one word (2 posts)

  1. M
    Member
    Posted 3 years ago #

    I've used the latest version of your plugin (the best so far!) for a couple of weeks now.

    It seems that in the snippet preview for the posts, the focus keyword is not recognized in the URL if there is more than one word.

    Example:
    - let's say the focus keyword for an article is the title of a movie - "Another Year"
    - when I just enter Another or Year separately, in the focus keyword field, the URL brackets gets green (for OK)
    - but if I want to enter the whole title "Another Year", then the snippet shows red, for error, where the URL is shown.

    I'm wondering if this is a default behavior or it is a bug.

    Any help is appreciated.

    Thanks!

  2. syerodriguez
    Member
    Posted 3 years ago #

    Can anyone help me out. I'm using the wordpress SEO plugin by Yoast and don't know what I'm doing wrong.

    My keyword is my URL.

    The tool said my keyword was in the domain when I made a page.

    I made the page my homepage and it says it's not in the URL anymore.

    The name of my website is how to get medical marijuana.

    The URL is http://howtogetmedicalmarijuana.co and my keyword is how to get medical marijuana.

    Is this a problem with the plugin that it doesn't recognize my keyword in the URL or is it a challenge with having this page my home page.

    What I mean is, does the SEO tool not recognize the domain as the keyword because it doesn't read as the page would read; "http://howtogetmedicalmarijuana.co/how-to-get-medical-marijuana?

    The page url is just my home site because it is my home page. That's why I say it shows the key word is in the URL when it's not my home page, but when I switch it to the home page it reads, as I wrote before http://howtogetmedicalmarijuana.co

    I would think it should show my keyword is in the URL in both cases, but for some reason it doesn't.

    I hope it is clear what I am asking. Please help if anyone knows the answer here.

    Thank you in advance.

    Sye

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic