WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Fatal error for RSS feed (7 posts)

  1. KEXINO
    Member
    Posted 3 years ago #

    Updated to v0.2.5.4, and now my RSS feeds (via Feedburner) come back with the following error:

    Fatal error: Call to undefined function is_post_type_archive() in /home/[nameofblog]/public_html/wp-content/plugins/wordpress-seo/frontend/class-frontend.php on line 191

    I have applied no settings via WPSEO under the "RSS" section.
    I can't update WP since my theme still doesn't play nicely with it. Can't dump WPSEO since I can't reimport the metadata back into something like AllInOneSEO. Really wish I never installed WPSEO.

    Stuck between a rock and a hard place. HELP!!

  2. hydn
    Member
    Posted 3 years ago #

    Same since latest update.

  3. hydn
    Member
    Posted 3 years ago #

    Feedburner count dropped big today :)

    Surprised no support on this yet. Once this is fixed I will never update this SEO again till updates are live for at least 30 days because fixes take too long. :/

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    You can whine all day long about the update taking too long but if you'd done the smart thing and updated to WordPress 3.1 you wouldn't have had this issue. So, update to 3.1 or wait for the next version of the plugin, which is actually a few days away.

  5. KEXINO
    Member
    Posted 2 years ago #

    If you'd bothered to read my original post you would see that updating to 3.1 isn't an option for me.

    Actually I HAVE already done the "smart thing" - I've dumped WordPress SEO and gone back to AllInOne SEO.

    It may not be as slick as WordPress SEO, but at least the updates don't break old installs. In addition, the developer doesn't use a public forum to insult his users.

  6. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    If your theme doesn't work with 3.1.1, fix your theme. Not only are plugin developers under no obligation to support older versions of WordPress, you are also placing your site at real risk of being hacked.

  7. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    If I've offended you, I'm sorry. This is truly something that makes me go mad though, to be honest. Read this post, you might understand me better.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic