WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Failed to stop the "Google Publisher Page" empty (5 posts)

  1. ciberwolf
    Member
    Posted 1 year ago #

    By not filling the "Google Publisher Page 'in WordPress SEO Plugin 1.2.7 Theme comes in <link rel="publisher" href=""/>

    It could be modified so that when one does not have "Google Publisher Page" not to leave the <link rel="publisher" href=""/>

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. BDHorrigan
    Member
    Posted 1 year ago #

    I'd like to second this – I'm getting a validation error as a result.

    Line 50, Column 31: Bad value publisher for attribute rel on element link: Keyword publisher is not registered.

    <link rel="publisher" href=""/>

  3. BDHorrigan
    Member
    Posted 1 year ago #

    Sorry, this was the bit I meant to copy:

    Bad value for attribute href on element link: Must be non-empty.
    <link rel="publisher" href=""/>

  4. Ardiansyah
    Member
    Posted 1 year ago #

    I'm too. For the moment I delete <link rel="publisher" href="' . esc_attr( $options['plus-publisher'] ) . '"/> from class-frontend.php

  5. zadro
    Member
    Posted 1 year ago #

    Change:

    echo '<link rel="publisher" href="' . esc_attr( $options['plus-publisher'] ) . '"/>' . "\n";

    To:

    if(substr($_SERVER['HTTP_USER_AGENT'], 0, 13) != 'W3C_Validator')
       echo '<link rel="publisher" href="' . esc_attr( $options['plus-publisher'] ) . '"/>' . "\n";
    }

    in frontend/class-frontend.php

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.