WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
%%excerpt%% UTF-8 bug (6 posts)

  1. dFactory
    Member
    Posted 1 year ago #

    WordPress version: 3.4.1
    WordPress SEO version: 1.2.8.4

    All meta descriptions auto-generated by %%excerpt%% tag do not contain non-latin characters (changed into "?" sign).

    It started in 1.28 and still works that way (on many different installations)

    Regards,
    Bart

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. dFactory
    Member
    Posted 1 year ago #

    For anyone looking for a solution:

    in /inc/wpseo-functions.php
    just change line 156, from

    '%%excerpt%%' => ( !empty( $r->post_excerpt ) ) ? strip_tags( $r->post_excerpt ) : utf8_encode( substr( strip_shortcodes( strip_tags( utf8_decode( $r->post_content ) ) ), 0, 155 ) ),

    to

    '%%excerpt%%' => ( !empty( $r->post_excerpt ) ) ? strip_tags( $r->post_excerpt ) : substr( strip_shortcodes( strip_tags( $r->post_content) ), 0, 155 ),
  3. dandr69
    Member
    Posted 1 year ago #

  4. sfinxbookcenter
    Member
    Posted 8 months ago #

    i try on my blog http://sfinx.me/ but doesnt work very good
    i think the plugin need improvements
    [signature moderated]

  5. jrf
    Member
    Posted 8 months ago #

    This is supposed to be fixed in v1.4.13. Are you using the latest version ?

  6. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

    @sfinxbookcenter - please stop using these forums to post links to your site - it's SPAM and will be deleted.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.