WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
ERROR: Your Sitemap appears to be an HTML page (7 posts)

  1. gooma2
    Member
    Posted 2 years ago #

    All my sitemaps created by WordPress SEO are now getting the following message:

    Sitemap is HTML
    Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.

    I've looked as much as I can on these, I'm rather confused why after all these months, only the WordPress SEO sitemaps are getting this error.

    I also use xml sitemap generator and it's fine...plus I created sitemaps from A-1 Sitemap Generator to compare and all those are fine in Google Webmaster Tools.

    Has anyone else had this issue, and is there a way to resolve besides just deleting all the WordPress SEO sitemap and going back to the other ones?

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. petervanderdoes
    Member
    Posted 2 years ago #

    Your sitemap_index.xml is in the page cache of W3 Total Cache. I would just exclude the sitemap_index.xml and all other sitemaps (post-sitemap.xml, page-sitemap.xml, category-sitemap.xml, post_tag-sitemap.xml,ngg_tag-sitemap.xml ) from the page cache.

    Hope this helps

  3. gooma2
    Member
    Posted 2 years ago #

    thanks so much for that!

  4. Jonathan
    Member
    Posted 2 years ago #

    Excluding from W3 Total Cache didn't do the trick for us. Is there anything else that could cause this issue?

  5. petervanderdoes
    Member
    Posted 2 years ago #

    Jonathan,

    Where is your sitemap_index.xml located?

  6. Jonathan
    Member
    Posted 2 years ago #

    The sitemap is located at http://www.fordasphalt.com/sitemap_index.xml. For some reason Google is no longer giving me the error now. Everything seems to be working.

    Even after clearing the sitemap from the page cache, Google had been saying it was in an incorrect format. Maybe it takes Google a while to refresh on their end.

    All is well now though. Thanks for the help.

  7. Edille Rosario
    Member
    Posted 2 years ago #

    Hi,

    I am having the same issue but I am using WP super cache.

    Hope someone could help..

    THanks..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic