WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Err 310 (net::ERR_TOO_MANY_REDIRECTS) (15 posts)

  1. PerguntasWP
    Member
    Posted 3 years ago #

    When I install WP SEO my pages don't load. If I uninstall they load fine. I get a message saying there were too many redirects. Err 310 (net::ERR_TOO_MANY_REDIRECTS. The hosting company tested all plugins and when testing WP SEO the pages stopped loading.
    What can be done?

  2. Daniel_N
    Member
    Posted 3 years ago #

    This happened to me as well, same error.
    But only when visiting the site with https:// it gets in a redirect loop.
    When loading the main page (index.php ?) it worked well, but all other templates and pages i got this error.

    http:// all worked fine. Haven't found anyone else with this issue so I disabled this plugin... until, hopefully, someone know a workaround or a fix for this.

  3. searcherati
    Member
    Posted 3 years ago #

    yep - right after installing the most recent update to version 0.2.3.2 there is a lovely 310.

    one guy fixed it but with no documentation here

    c'mon toast, give us some butter.

  4. Daniel_N
    Member
    Posted 3 years ago #

    It seems that the SSL redirect loop is gone, now getting redirect errors when using qtranslate plugin and switching to secondary language.

  5. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Disable the clean permalinks function.

  6. Daniel_N
    Member
    Posted 3 years ago #

    YES!!! that worked.

    Thank You!

  7. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    :) that function doesn't have a warning next to it just because I think it's cute :)

  8. reihanzo
    Member
    Posted 3 years ago #

    im sorry, this may sound unsavvy but i am having the same issue and i cannot seem to find a way to disable the clean permalinks function. Can you tell me where to find that?

  9. Daniel_N
    Member
    Posted 3 years ago #

    You can find it in the SEO->Permalinks setting page disable the option:

    Redirect ugly URL's to clean permalinks. (Not recommended in many cases!)

  10. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    I'm seriously considering removing that functionality altogether :)

  11. steveknarf
    Member
    Posted 2 years ago #

    Help! I'm receiving the same - just for my 'blog' page - and my ugly URL redirect is off (and always has been). However, I did recently change my setting to a 'custom' permalink structure. Is this causing the error? How can I fix, and keep my custom settings in tact?

  12. steveknarf
    Member
    Posted 2 years ago #

    PS. I actually just receive it when trying to access my RSS feed, /feed

  13. steveknarf
    Member
    Posted 2 years ago #

    Disregard. Uninstalling FeedSmith plugin did the trick.

  14. syynapse
    Member
    Posted 2 years ago #

    Hi,
    I have the same problems Err 310 (net::ERR_TOO_MANY_REDIRECTS). Please note that I follow every steps read on this topic and on official site of this wonderful plugin. Is interesting that on firefox it ok but with IE and chrome I heve the problem.
    Any idea? Please help me...
    Thank you very much.

    Crismer

  15. erick_paper
    Member
    Posted 2 years ago #

    I have the same issue today.

    It's this that does this:

    "Strip the category base (usually /category/) from the category URL."

    Why does it do this? When I disable this function, the site works. Otherwise too many redirects.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic