WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Dynamic page title numbering not working if only one page of result (11 posts)

  1. jp2112
    Member
    Posted 2 years ago #

    Apologies if this has been mentioned already.

    I have the titles set up for search results pages to show "Search results for '%%searchphrase%%', page %%pagenumber%% of %%pagetotal%%". There are similar settings for Category, Tag and Author archive page titles. My site is set to show 5 results per page.

    When there are five or less search results (one page), the title shows "Search results for "search term", page of", basically leaving out the dynamically generated page numbers.

    Example:

    Search for a popular term on my website returns 59 articles (12 pages):
    http://www.jpsoftwaretech.com/search/MSXML -- title is correct

    Search for a less-used term returns 5 articles (only one page of search results):
    http://www.jpsoftwaretech.com/search/GetFilename -- title is incorrect

    Can anyone else reproduce this behavior? I assume it is the way the plugin calculates the number of pages of search results. I'll try to hack my way through the plugin and see if I can create a patch.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    I can't reproduce this on 1.1.9 with a clean install... Which version of the plugin are you running? And which theme? Have you tried it on a standard theme?

  3. jp2112
    Member
    Posted 1 year ago #

    I am using v1.1.9, with Genesis framework and Fairway child theme. I'll start deactivating plugins to see if one of them is the problem.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Please do, curious to find out what's causing this.

  5. jp2112
    Member
    Posted 1 year ago #

    Deactivating plugins didn't do anything. Neither did changing to the Twenty Eleven theme. I changed the search page meta title to this:

    Search results for '%%searchphrase%%', %%page%%

    and it shows

    Search results for 'search term', Page of 1

    It simply refuses to show 'Page 1 of 1' if there is only one page of search results. I'll keep messing around with plugins and settings and see if I can fix it.

  6. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Found it. It'll be fixed in the next version.

  7. jp2112
    Member
    Posted 1 year ago #

    Awesome Joost, thanks for looking into this.

  8. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for your persistence!

  9. Ozias
    Member
    Posted 1 year ago #

    Glad I found this post! I am having the same issue. Great to hear it will be resolved. Thanks so much!

  10. fabusdr
    Member
    Posted 1 year ago #

    I have the same problem and I'm happy it will solved soon, great! Can not wait for the new version of the plugin!
    Thank you for your wonderful work :-)

  11. jp2112
    Member
    Posted 1 year ago #

    Just upgraded to 1.2, confirmed that this is fixed. Thanks for seeing this through Joost!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic