WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Doesn't show meta text correctly (5 posts)

  1. DMX123456
    Member
    Posted 2 years ago #

    I am using WordPress SEO by Yoast and my SEO title shows up correctly in Google. However my meta text is not, it is showing a part of the text that is on my page instead of the text I filled in at the plugin. I am already waiting for a few months but I doesn't refresh. What can I do?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Marco Milesi
    Member
    Posted 2 years ago #

    Same problem. I use this plugin in all of my websites but since the 3.4.1 upgrade in many of them i have found some bugs related to pages' titles (re-enable the plugin fixed it) and related to meta tags.
    For example by searching the website in Google the title appears correctly but the description is, as you, "A part of the text that is on my page instead of the text I filled in at the plugin".

    Hope to solve this problem. Thanks in advance!

  3. mikeotgaar
    Member
    Posted 2 years ago #

    Hi there.
    Have a look at your page source.
    The meta description syntax should be
    <meta name="description" content="the meta description you want"/>

    I think Google may just be choosing to use the content instead of the set description. There is no absolute guarantee Google or other engines will use the meta description...
    The other thing you can try - add the "noarchive" robots tag to the post/page for a few weeks; that may force a refresh (eventually) Google will still index the page.

  4. Marco Milesi
    Member
    Posted 2 years ago #

    Hi. Thanks for your reply.

    In didn't found that meta tag in my websites (i think that the plugin doesn't create it anymore). Now i've put it manually in the header.php!

  5. mikeotgaar
    Member
    Posted 2 years ago #

    That works...

    Note for anyone else following this thread - The No Archive tag is found in "Advanced" tab - Meta Robots Advanced: on individual posts and pages - there's no option in the plugin to set this site wide. (it's very seldom used and confuses many!)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic