WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Disable title rewriting by Yoast (12 posts)

  1. OC2PS
    Member
    Posted 2 years ago #

    I have just installed SEO by Yoast.

    I am quite unhappy with the page title rewriting done by Yoast, and was quite happy before.

    Any way to disable title writing by Yoast? I didn't see a checkbox.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Ming Sheu
    Member
    Posted 2 years ago #

    I don't believe there's an "option" to turn features on/off. However, it you clear out all of the "title" fields then the plugin will not rewrite the titles.

    Clearing out the title templates from the settings page is easy.

    Clearing out the titles per post/page if you have fixed titles will take time unless you're familiar with your database.

  3. OC2PS
    Member
    Posted 2 years ago #

    All fields on Title tab are already empty...I never entered anything there...

  4. Ming Sheu
    Member
    Posted 2 years ago #

    What about the WordPress SEO fields per post or page?

    Did you uncheck "Force rewrite titles"?

    Do you have a sample of the output or a link to the site?

  5. OC2PS
    Member
    Posted 2 years ago #

    I did not check "Force rewrite titles".

    I did not add any values to the per page fields yet.

    http://www.csillamvilag.com

  6. Ming Sheu
    Member
    Posted 2 years ago #

    Have you flushed the cache to make sure you're viewing the updated page titles?

  7. OC2PS
    Member
    Posted 2 years ago #

    Yup

  8. Ming Sheu
    Member
    Posted 2 years ago #

    Ok, so I think here's the issue and you have some options

    1) There is no way to turn off just the title rewrite for WordPress SEO

    a) Even if you leave the title template field empty it will rewrite the title

    2) Your template is appending values to wp_title()

    a) To overcome this, you can enable "Force rewrite titles" however this feature is a little buggy and doesn't address themes that have new lines in the title tag

    3) It looks like you are using the Weaver theme

    a) If you are, look for a setting for SEO plugin friendly titles. I didn't install the theme but from header code it looks like there's a setting to use wp_title() which would work with WordPress SEO

    I hope that all made sense.

  9. OC2PS
    Member
    Posted 2 years ago #

    That worked!

    In Appearance > Weaver Admin > Advanced Options > Site Options > SEO Tags
    I checked the box Use SEO plugin instead.

    One problem, though: Now the title for the home page has disappeared, and the URL is shown in the tab header.

  10. Ming Sheu
    Member
    Posted 2 years ago #

    Now that you have the setting checked in the Theme options, try setting the WordPress SEO options. They should work now.

  11. OC2PS
    Member
    Posted 2 years ago #

    What's the option I need to use in order to fix the title on homepage?

    (the title on other pages is already exactly as I want it)

  12. Ming Sheu
    Member
    Posted 2 years ago #

    It depends on how you have your site setup.

    Do you have an input field for Admin -> SEO -> Titles -> Homepage -> Title template:

    Enter the pattern you want or a literal string of the value you want.

    Or, does it link you to a page you have setup as your static homepage?

    I believe on the page field you have to enter the literal string value.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic