WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Disable the date-based archives seems to be permanently set (10 posts)

  1. redactuk
    Member
    Posted 2 years ago #

    Now upgraded to 1.2.5 and have the following issue:

    I have my Date Archives set to noindex, nofollow but do NOT have Disable the date-based archives ticked, yet still clicking any dates archive links takes me to home page. I've disable SEO and they work again, then reenable and they don't work again. All the time the Disable the date-based archives is NOT ticked. Amny suggestions?

    Thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. redactuk
    Member
    Posted 2 years ago #

    Any updates on this?

    Note: I appreciate the work you have done Joost on this awsome plugin, but this recent series have updates have cause major problems. I guess a lot is maybe due to wp4+ updates also. Hopefully you will get a handle on these and 1.2.6 will sort everything out

  3. redactuk
    Member
    Posted 2 years ago #

    Hope Joost hasn't done a runner :(

  4. Michael Van Den Berg
    Member
    Posted 1 year ago #

    I'm experiencing the same problem right now. Just wanted to check what would happen if I checked the "disable the date-based archive"-option. Now I've unchecked it but it still directs me to the frontpage. When I disable WordPress SEO the date based archives work again. Very frustrating....

    And here another one with the same problem: http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-archives-and-indexation-not-unchecking-when-saved

  5. krissybwuteva
    Member
    Posted 1 year ago #

    I had the same problem and was able to fix it. Under your SEO settings, go to 'Other'. Under 'Date Archives' you'll see 'Meta Robots'. make sure the box where it says 'Disable the date-based archives' is NOT checked. Mine was checked automatically and when I unchecked it, it flushed my cache. when I checked my site and went to a monthly archive it displayed the page correctly starting with the oldest post of that month first and so on. Hope this helps!

  6. susie.Q
    Member
    Posted 1 year ago #

    The date archives does not work with this plugin and unchecking the the 'Disable the date based archives' found in 'other does' not fix it.

    When the plugin is deactivated the date archives works find. Has anyone else found a way around this.

    I really like this plugin, but not having a usable archives is a deal breaker for me.

  7. philiphotog
    Member
    Posted 1 year ago #

    This worked for me. If you find that the archives widget is not working, disabling it unchecked will solve the issue.

  8. Niramaya
    Member
    Posted 1 year ago #

    The fix suggested by @krissybwuteva and @philiphotog does not work for me, has anyone found another workaround? Thanks.

  9. susie.Q
    Member
    Posted 1 year ago #

    It finally worked when I checked 'no index, follow' and unchecked 'disabled the date archives' boxes in the Date Archives section. I also emptied the wp cache and my browser cache.

  10. Niramaya
    Member
    Posted 1 year ago #

    hmm, that's exactly what i have/did, but no such luck.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.