WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Disable link rel="author" on pages (5 posts)

  1. Debiprasad Sahoo
    Member
    Posted 2 years ago #

    WordPress version: 3.4.1
    WordPress SEO version: Development and 1.2.5

    I did this: Added link to Google+ profile on my user profile page.

    I expected the plugin to do this: I expect the plugin to not to add the link rel="author" to my Google+ profile on pages.

    Instead it did this: It adds the link rel="author" to my Google+ profile on pages.

    Why it's a problem:
    The website where I am using this, if my company website. I want my Google+ profile to be displayed on Google results, when it displays any result from the blog of company website. But it should not display my Google+ profile on the results where other pages and the index page (it uses a page).

    http://d.pr/i/wBa2

    http://d.pr/i/7HEW

    I think there should be an option to disable this on pages. I hope you will include this in future release.

    Is there any workaround to disable this on page? Some code, which I can modify by editing the plugin files or can add in the functions.php file of the theme?

    While writing this message, another workaround came to my mind. I can create another user and assign that user as the author of the pages.

    Thanks,
    Debiprasad

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    there is an option, check the WordPress SEO API docs.

  3. Debiprasad Sahoo
    Member
    Posted 2 years ago #

    I modified is_singular() to is_single() on line 708, author() function of Frontend Class (WPSEO_Frontend) file and it works as I need it. But the problem is I need to do this every time I update this plugin. What's the best way to make this modification, which will not affected by plugin update?

  4. bfred.it
    Member
    Posted 1 year ago #

    Alternatively, I think you could assign the pages to a dummy WP profile for the company and leave the blog posts to your name.

  5. mpierce84
    Member
    Posted 1 year ago #

    @Debiprasad Sahoo Thanks for the workaround. Line number has been updated but if you look in the Frontend file and search for author you can find line to edit. In today's version seems to be line 726 for anyone interested.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic