WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
delete meta description (48 posts)

  1. eoolk
    Member
    Posted 1 year ago #

    Hi
    Love your work first of all!
    The plugin wants me to dele the theme original meta description, from the plugin panel i get this message"
    Your theme contains a meta description, which blocks WordPress SEO from working properly, please delete the following line, or press fix it:
    <meta name="description" content='<?php echo get_bloginfo( 'description', 'display' ) ?>' />
    "
    i tried to delete this both by using the delete button function and manual delete the line in the header.php
    But still i get the same message...what should ido and is there some special order to solve....
    hoping for help...
    cheers
    eoolk

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. tizz
    Member
    Posted 1 year ago #

    Same here.

  3. tizz
    Member
    Posted 1 year ago #

    Update: when I try to fix it automatically, this is the error:

    Warning: fopen(.../wp-content/themes/clear-line/header.php.wpseobak) [function.fopen]: failed to open stream: Permission denied in .../wp-content/plugins/wordpress-seo/admin/pages/dashboard.php on line 35

    I've set up permissions in both files, theme's header.php and plugin's dashbooard.php, but nothing change.
    Of course, I also removed the line <meta name="description" content="<?php echo $meta['description']?>" />, and then all the line
    <?php if ($meta['description']) {?><meta name="description" content="<?php echo $meta['description']?>" /><?php } ?>

    So, currently I don't have no more line in the header for the meta description, but the plugin's signal is still there, after refresh and cache cleaned, and warning reappears if I try to fix it.
    In the source, the right plugin meta description is there, like it was before, as usual, so I think that new check to see whether the theme contains a hardcoded meta description doesn't work well.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    The meta description line is gone now? Yet the notice still appears? Even when you click fix it again?

    If so, could you please test the development version... You can download the development version from here, or you can download it directly here.

    Please make sure to enable tracking and tell me what your URL is, might help me to find the issue more easily.

  5. ash444b
    Member
    Posted 1 year ago #

    I have same for this <meta name="description" content="<?php bloginfo('description'); ?>" />

  6. tizz
    Member
    Posted 1 year ago #

    The meta description line is gone now? Yet the notice still appears? Even when you click fix it again?

    Yes it's just like that, and when I click fix it the warning message appear. I haven't tried dev. version because others times for other problems dev. version has never worked, so I'm waiting for someone else who have this same problem (here's another one), and a quick fix.
    Apart from the wrong error plugin message, I don't think there are malfunctions, because in the source I can read meta-description.
    I don't even update to 1.2.8.1 because I read about people with worst problems, so I think I can wait 'til a stable version.
    My URL

  7. RichardWantsToKnow
    Member
    Posted 1 year ago #

    Is there a fix?

  8. juliangav
    Member
    Posted 1 year ago #

    Same here...?

  9. guilherme de lacerda
    Member
    Posted 1 year ago #

    Same here...²

  10. RichardWantsToKnow
    Member
    Posted 1 year ago #

    Even a comment from the author saying he's working on it would help....
    It's been at least 3 days.
    Why would anyone want to try a beta version? I'm not that stupid.
    Time to go back to All-In-One. It's not free, but I wouldn't have wasted all this time either. That's worth well over the cost of the AIO.
    Thanks Yoast!

  11. RichardWantsToKnow
    Member
    Posted 1 year ago #

    Above the author states, "Please make sure to enable tracking and tell me what your URL is, might help me to find the issue more easily."

    My question, "WHICH TRACKING?"
    Again with the incomplete sentences and partial instructions.
    He writes like we can read his mind and that we understand all that he does. If we did, we wouldn't need his plugin!
    Try writing for the audience.

  12. guilherme de lacerda
    Member
    Posted 1 year ago #

    I did install 1.2.8.2 and the error still stay. =(

  13. Stefan Moravcik
    Member
    Posted 1 year ago #

    Hello All,

    I had very same problem today, but the fix can be done, by deleting the meta header line and then pressing Save Settings at the bottom of the Dashboard page of the SEO. (at least it disappeared after that for me)

    Second of all, I just have to react on Richard's comments. Those comments are rubbish. First of all, to enable tracking make a lot of sense. It is just you being lazy to have a look at the first page of the SEO and see the first tick box which is called Tracking.

    So no need for you to read any mind. It wouldn't be possible for you anyway, you can't even read the first page of the SEO dashboard.

    Nobody force you to use this plugin, people who can't appreciate the work of others should be banned from Open Source.

  14. guilherme de lacerda
    Member
    Posted 1 year ago #

    I had already done that, but it didnt work with me. =(

  15. RichardWantsToKnow
    Member
    Posted 1 year ago #

    Stefan,
    Thanks for your opinion.
    But I might point out your insulting me isn't any different than my comments on the author of the plugin.
    I did see read and see the first page. However, since the author didn't take the time to differentiate, and there is more than one tracking available in webhosting, his instructions were quite incomplete and not clear. He has a habit of that; it was not unique to this problem. Similarly, after three days he still had not responded to those of us having the problem. Not even a response saying he was working on it. Quite rude in my opinion.
    As for your comments, I think you just stepped on your own toes.
    And as you will notice from Guilherme's post, your attempt at a solution failed for him. If I was to call anything 'rubbish' it would be your fix. So please, stop with the arrogance. You are not the Open Source god.

  16. RichardWantsToKnow
    Member
    Posted 1 year ago #

    Notice of the new update of the plugin, v.1.2.8.2 was received this morning. We updated. No change: same problem, no solution, no response from the author.
    Anyone else had any success after this upgrade?

  17. RichardWantsToKnow
    Member
    Posted 1 year ago #

    To all,
    This may be an option.
    See if your theme has a built-in SEO option. In other words, did the theme author include SEO in the theme. If so, try disabling it. Then try to refresh your browser for the WPSEO dashboard and see if the problem still exists.

  18. guilherme de lacerda
    Member
    Posted 1 year ago #

    after I did the update v1.2.8.2 my title is no longer shown. Any suggestion anyone?

  19. guilherme de lacerda
    Member
    Posted 1 year ago #

  20. eyeonbooks
    Member
    Posted 1 year ago #

    Stefan's solution worked for me - clicked "Fix", scrolled down and clicked "Save," and the red error message went away. (This was after I upgraded to v1.2.8.2)

  21. guilherme de lacerda
    Member
    Posted 1 year ago #

    About the title the problem is Resolved ppls, i just did remove the code of in my head.php `<title><?php if ( is_category() ) {

    echo 'Category Archive for "'; single_cat_title(); echo '" | '; bloginfo( 'name' );
    	} elseif ( is_tag() ) {
    		echo 'Tag Archive for "'; single_tag_title(); echo '" | '; bloginfo( 'name' );
    	} elseif ( is_archive() ) {
    		wp_title(''); echo ' Archive | '; bloginfo( 'name' );
    	} elseif ( is_search() ) {
    		echo 'Search for "'.wp_specialchars($s).'" | '; bloginfo( 'name' );
    	} elseif ( is_home() ) {
    		bloginfo( 'name' ); echo ' | '; bloginfo( 'description' );
    	}  elseif ( is_404() ) {
    		echo 'Error 404 Not Found | '; bloginfo( 'name' );
    	} elseif ( is_single() ) {
    		wp_title('');
    	} else {
    		echo wp_title( ' | ', false, right ); bloginfo( 'name' );
    	} ?></title>

    to simply </title><?php wp_title();?></title>

    About the <meta name="description" content='<?php echo get_bloginfo( 'description', 'display' ) ?>' /> error, just delete the code in ur head.php go to panel and click "Fix", scrolled down and clicked "Save," and the red error message went away.
    all is working now.
    thx ppls,
    and sorry about my english. ^_-

    [Moderator Note: Please post code or markup snippets between backticks or use the code button. As it stands, your code may now have been permanently damaged/corrupted by the forum's parser.]

  22. tizz
    Member
    Posted 1 year ago #

    @ Stefan. Your solution is fine, thanks. How come I didn't thought before about this? :) Usually clickin' save in the Yoast plugin fixes all :))
    Clicked on fix it, then on save and the error and warning messages disappeared. Then updated to 1.2.8.2 and everything seems OK.
    Now I can also see "tracking", with the error it was disappeared at all.

    @ Richard. Theme built-in SEO should be disabled in any case if you use a SEO plugin.

  23. Stefan Moravcik
    Member
    Posted 1 year ago #

    @Richard, i guess my fix wasn't a rubbish after all ;)

  24. albertosala
    Member
    Posted 1 year ago #

    @stefan, good job mate it did work for me as well, people just make sure you click save

  25. mikegale
    Member
    Posted 1 year ago #

    I'm also having this problem.
    My site:
    http://www.disastercake.com

    My Error:

    Your theme contains a meta description, which blocks WordPress SEO from working properly, please delete the following line, or press fix it:
    <meta name="description" content="<?php if ($my_meta['seo'] != '') { echo $my_meta['seo']; } else { the_excerpt_rss(); } ?>" />

    Pressing fix it then save does not make the error go away. I can also not find this code anywhere in my files to manually delete it.

  26. Charles de Vre
    Member
    Posted 1 year ago #

    Same problem here after upgrading WP SEO.
    I pressed for both lines the Fix-it button in the plugin's dashboard, pressed Save Settings: red warning message was still there.
    [My theme: Magazine Premium by Bavotasan. Built-in SEO turned off.]
    Only after I manually deleted the 2 lines from the header.php,
    the warning was gone.

    I brought this up in the themes forum; theme developer's reaction:
    "The line will not go away in the PHP file [after you turn the built-in SEO option off] because it needs to be there in case you want to turn it back on. Whatever warning the WP SEO plugin is giving you can be ignored because once the SEO options in MP is turned off that meta description line will not appear on the front end."

    Whole topic: http://themes.bavotasan.com/support/discussion/2128/wp-seo-upgrade-causes-problems-in-magazine-premium/#Item_1

    I'm not sure what to do. Think I'll put the 2 lines back in header.php. I really hope that Joost de Valk will comment on this.
    Thx.
    My site http://charlesdevre.nl

  27. Sean O'Dwyer
    Member
    Posted 1 year ago #

    I just followed the instruction above to click the SAVE button, and it worked for me — I noticed a note that the cache had been cleared, which makes me think: if you have any caching going on, that might be why you're still seeing the error after deleting the offending line from header.php. Makes sense? (Or it could have just been a coincidence…)

  28. aeboi80
    Member
    Posted 1 year ago #

    I also experienced this issue with the meta description reporting as being incorrect. I Clicked the fix it button, nothing happen. I physically edited the header.php and removed it. Still nothing.

    I then returned to the plugin, hit fix it AND THEN clicked save settings.

    It fixed it!!!

    If Joost is still watching this thread I just wanted to let you know that I love your plugin and I have tracking turned on and it works great. I've been using it on many of our sites and it still ranks supreme in the SEO plugins for wordpress.

    To the naysayers out there. Please keep in mind that Joost is very well respected in the WordPress community and SEO community. Just because someone doesn't reply immediately doesn't mean you are being ignored or that their plugin sucks.

    Opensource software comes with some expectations and as such you have to agree to accept them when you install them. Let's all keep in perspective the amount of personal time plugin developers devote to the creation and on going UNPAID support of the plugin.

    Thanks again for an amazing plugin that I am thankful has been in my arsenal.

  29. bobdobbs
    Member
    Posted 1 year ago #

    Stefan's fix worked for me.

    In the dashboard for the plugin, I clicked on 'save settings' and the warning vanished.

  30. ChicDenim
    Member
    Posted 1 year ago #

    None off the above worked for me. I can't seem to clear the error message. I am using a new theme, got the error message, deleted the code from my header.php file and it worked. However, the theme was recently updated to include meta data and now getting rid the error message has been impossible. I really like this plugin, but I wish the bug would get fixed soon.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic