WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
category-sitemap.xml missing (6 posts)

  1. mateuszdraco
    Member
    Posted 1 year ago #

    WordPress version: 3.4.1
    WordPress SEO version: 1.2.5

    I did this: Installed plugin, enabled sitemaps in plugin. Everything went just fine, I was very happy. I added one category and then category-sitemap.xml just gone. All I see now is 404 message.

    I expected the plugin to do this: generate xml properly.

    Instead it did this: gives me 404 page. I open sitemap page, click Sitemap XML, it opens as it should. every other XML works, every but category-sitemap.xml.

    I have a feeling I did something wrong but I dont know what. I did try millions times to disable it, enable it, change any options I found but I had no luck :(

    sitemap: http://bednarska.mdraco.com/sitemap_index.xml

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. ccalvogc
    Member
    Posted 1 year ago #

    Hi

    I had the same problem and finally today I've fixed. http://www.gincanaland.com/category-sitemap.xml

    First if you have installed W3 Total Cache: under Browser Cache, try to disable "Set W3 Total Cache header" for HTML & XML and clean all caches.

    But for me that wasn't enough, I had to fill all boxes of Yoast WordPress SEO Categories in Edit Category page for all categories including uncategorized. Besides, I had to check the 2 last combos without using default values.

    After that, I save changes in Sitemaps XML page. I hope it works for you too. Good luck

  3. Mike Imken
    Member
    Posted 1 year ago #

    I had the same issue. Like ccalvogc mentioned, it required going into the Categories. I changed "Include in Sitemap" setting to Always include from "Auto Detect".

    Then all the categories showed up on the category sitemap and no 404 error.

  4. Olaf Lederer
    Member
    Posted 1 year ago #

    Yep "always include" on the category page did the trick (I can live with that)

  5. Mark
    Member
    Posted 1 year ago #

    I noticed the same issue today. I know my category sitemap was fine before I went in and added SEO info for each category yesterday. Sure enough going back and changing to "always include" on each one fixed it. Thanks for the helpful info!

  6. RachaelButts
    Member
    Posted 1 year ago #

    1. By going to "posts">"categories" >
    2. Click edit under the category you have created
    3. Once on the category edit page Click the drop down box that says "Include in sitemap?:"
    4. and change to "always include".
    5. Then click save.
    6. May need to do this to all of your categories.

    I did what the people above said to do but I thought these were a little better directions

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic