WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Bug in advanced robots setting implementation (2 posts)

  1. dashaluna
    Member
    Posted 3 years ago #

    Hello,

    I think there must be a bug in the advanced robots settings implementation. Plugin version: 0.4.2

    I'm going the following:
    1. I've changed "Meta Robots Index" (index) and "Meta Robots Follow" (nofollow) settings in the "Advanced" tab in the "WordPress SEO by Yoast" metabox when editing a page.
    2. When viewing all the pages, the "Robots Meta" column has got correct values: Index, Nofollow.

    However, when I view page's source the robots meta comes up as <meta name='robots' content='noindex,nofollow' />

    I think this could be happening because of "Meta Robots Advanced" setting in the same "Advanced" tab. This setting is preselected as "None", which for robots means "noindex, nofollow". And that seems to have a precedence over my manually set up settings in "Meta Robots Index" and "Meta Robots Follow" fields.

    Maybe preselected value should be not "None", but something like "Use manually setup setting above" or the way that robots meta tags are created should be fixed.

    Hope that makes sense.

    Thanks,
    Dasha

  2. dashaluna
    Member
    Posted 3 years ago #

    Also, I have noticed the following:

    After specifying "Meta Robots Advanced" setting as "NO ODP" and "NO YDIR" on the "Advanced" tab when editing a page, the following line appeared in the page's source:

    <!-- This site is optimized with the Yoast WordPress SEO plugin v0.4.2 - http://yoast.com/wordpress/seo/ -->
    <meta name='robots' content='noodp,noydir'/>
    <!-- / Yoast WordPress SEO plugin. -->

    So that's good. However, the "Meta Robots Index" (set as index) and "Meta Robots Follow" (set as follow) settings on the same "Advanced" tab, don't seem to appear in the source.

    I did notice that the following line is coming through:

    <!-- wordpress head functions -->
    <meta name='robots' content='noindex,nofollow' />

    It looks like this line is coming through via wp_head(); hook. I don't have any other SEO plugins than "WordPress SEO". Is there global settings that keep outputting "noindex,nofollow", and if so, why per page settings don't overwrite global ones?

    I would really appreciate any help!
    Many thanks,
    Dasha

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic