WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Breaks the TinyMCE editor on HTML tab (8 posts)

  1. gmangesh
    Member
    Posted 2 years ago #

    The TinyMCE editor on HTML tab is blank when WordPress SEO plugin is enabled.

    I see this JS error in the JS console:
    Uncaught TypeError: Object [object Object] has no method 'zIndex'

    This is caused by this line in wp-seo-metabox.js:
    jQuery('#yoast_wpseo_focuskw').autocomplete({ ...

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. gmangesh
    Member
    Posted 2 years ago #

    Found the issue.
    Looks like there was a jQuery UI version mismatch.
    The site also uses MagicMember which was configured to use jQuery UI v1.7.2
    Whereas WordPress SEO (or someone else) was loading 1.8.16

    Configured MagicMember to use jQuery UI 1.8.16 and TinyMCE is back.

  3. rajupp
    Member
    Posted 2 years ago #

    It would be great if you can let me know how you fixed it. How to know which plugin is clashing with WordPress SEO and then how to make it use jQuery UI 1.8.16?

  4. gmangesh
    Member
    Posted 2 years ago #

    Hi Raju,

    He did I know it was a jquery clash: the error I saw was in the jquery ui code itself. The jquery ui code was being called by the jquery core library (you can see the call stack in chrome developer tools' JavaScript console). Based on this my first suspicion was a version mismatch.

    How did I know it was caused by WordPress SEO plugin: it was the last plugin I had installed. So I enabled/disabled it a few times and saw that the problem appeared when this plugin was enabled (although it was not caused by the plugin per se)

    how did I find out magic member was causing the jquery version clash: I got lucky. I went through the admin screens of m theme and all installed plugins till I found a configuration for the jquery version in the MagicMember admin screen. I changed it to use the latest jquery version and the problem went away.

    If I had not found a configuration in any plugin screen then my next move would have been to do a grep through the code of all the plugins and theme to see if any jquery tag was hardcoded somewhere. You can also use chrome's developer tools to see which JS resources are being loaded and see if that provides any clues.

    Hope that helps.
    Mangesh

  5. rajupp
    Member
    Posted 2 years ago #

    Thanks Mangesh,
    With my limited ability to play with codes and consoles, I found that my theme has some hardcoded references to jquery ui, but couldn't fix it. I had to Hide WordPress SEO box on edit post pages. Dirty fix, but works

  6. gogui
    Member
    Posted 2 years ago #

    Hey !
    I have the same problem. But I'm only using WP SEO YOAST at this time and the Tiny MCE is missing...

    Someone can help me ?

    For information : all my WP version et plugin are updated, i'm using my own theme based on twenty-eleven (I only modified the css and a little the php).

    For information 2 : i'm french, so I don't know if my english is good...

    Greg

  7. gmangesh
    Member
    Posted 2 years ago #

    Hi Greg,

    Do you see any JavaScript error on the screen?
    If you use Chrome you can see it in Chrome's developer tools. If you use FireFox then Firebug's console will show you if there are any JS errors.

    Mangesh

  8. gogui
    Member
    Posted 2 years ago #

    I found the error...

    I added this code in the function.php

    /**
    *Langage du theme
    */
    load_theme_textdomain('MVP', get_template_directory() . '/languages');

    I don't remember why I added this code... So i deleted it and it works again !

    Thanks you for your answer !

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic