WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Auto-Sitemap Error (7 posts)

  1. jpmitchell
    Member
    Posted 3 years ago #

    When enabling the sitemap functionality - my sitemap.xml file always gives this error:

    This page contains the following errors:
    error on line 1 at column 1: Document is empty
    Below is a rendering of the page up to the first error.

    Anyone know how to fix this as it is interfering with Google's ability to be notified and indexability of the site?

  2. jpmitchell
    Member
    Posted 3 years ago #

    Not sure if this was the issue, but I thought I'd share what I did and seemed to fix it.

    1. I upgraded to 3.1
    2. I determined it was an upload path problem - other WordPress SEO error displayed.
    3. Changed the settings for the Media (Settings>Media) to be blank [not specified].

    Hope this helps anyone else with this problem.

  3. worldli
    Member
    Posted 3 years ago #

    I don't have that setting under my Settings>Media menu. Any other suggestions to fixing this problem? I really need a sitemap!

  4. jpmitchell
    Member
    Posted 3 years ago #

    What WP version are you using?

  5. worldli
    Member
    Posted 3 years ago #

    3.0. We don't really want to upgrade at the moment as we have just got everything stabilized, site performance wise, but it seems strange that it wouldn't work in 3.0!

  6. jpmitchell
    Member
    Posted 3 years ago #

    You should have that navigation on the left. Click on the arrow next to "Settings", then click on "Media" and you'll see what I was referring to.

    Good Luck!

  7. worldli
    Member
    Posted 3 years ago #

    I don's see it on my backend, if I could attach a screenshot I would!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic