WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Author Links are redirected to Home Page (3 posts)

  1. darinroman
    Member
    Posted 2 years ago #

    The website is running WP v 3.4.1 and WordPress SEO v 1.2.5.

    When an author link is clicked in a post's meta: the_author_posts_link() it redirects to the homepage rather than the author.php or archive.php template.

    This problem only occurs with the SEO plugin active and I cannot find a setting within the plugin that would affect this behavior. A search for this problem returned a resolved issue from 6 months ago that does not apply to this version of the plugin.

    Apparently there used to be an Indexing > Archive Settings page within the plugin admin and a check box to disable the author archives, therefore, un-checking this box was the solution. However, I do not see this option in the current version and the author archives are definitely being disabled.

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-author-urls-redirected-to-home-page-when-activate-wordpress-seo-by-yoast?replies=2

    Does anyone have the same issue and a solution?

    Thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Alexander Gieg
    Member
    Posted 2 years ago #

    Go to SEO -> Titles & Meta -> Other. The option is there within the Date Archives section.

  3. darinroman
    Member
    Posted 2 years ago #

    Thank you for the quick reply Alexander.

    I had missed it due to a plugin conflict.

    It turns out, the 'All-in-One Calendar' by Then.ly causes all of the tabbed content (except for the Save Settings button) on the SEO Titles & Metas page to disappear.

    I am going to notify the developers as I'd like to keep both.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic