WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Are SEO Titles not automatically filled in anymore? (15 posts)

  1. AG_Mike
    Member
    Posted 2 years ago #

    http://addicted-gamers.com
    http://facebook.com/AddictedGamers

    I noticed the other day when I posted a couple of links on our facebook that there weren't any titles for the articles. You can see it on the last three posts compared to the previous ones. I thought there might be a problem with the SEO so I dug as much as I could.

    I came to realize that the SEO Title is no longer automatically generated off of your Snippet Preview when you create posts. You now have to hit the button to generate it.

    My question is, is that intentional or will there be an auto-generate fix? The only reason I ask is I have some "editors" working on the page that are rather stubborn when being asked to do certain technical things in posts, and yes, even something as simple as clicking that button will be a pain to keep up on.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. AG_Mike
    Member
    Posted 2 years ago #

    A note, I generated SEO titles in the articles on those 3 posts. I have since deleted them on Facebook in order to relink them. Facebook still doesn't show any title, so I'm still wondering if even after generating the SEO title if maybe it isn't being recognized.

    You will still be able to go to our Facebook link and see the very first article still has no title where the -addicted-gamers.com is instead of a full title and url.

  3. RickRottman
    Member
    Posted 2 years ago #

    Titles don't seem to be working for me either. Posts now don't have the site's name.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    What are your templates under SEO -> Titles?

  5. AG_Mike
    Member
    Posted 2 years ago #

    So this is where I'm not the most proficient as I'm not even entirely sure how the templates work. Before the update, I didn't have any templates defined.

    Now, I also don't, but I don't entirely know how they work either. If I create a template, should it be generic that it will be the same for every post or will the plugin create a unique title based on the template for each post?

    Either way, like I said, before the update, it seemed fine, essentially taking care of it all automatically for me. Now, it doesn't seem to be. This is the part where I should be dedicating more time to learning and knowing this stuff anyway.

  6. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Try setting a template like this:

    %%title%% - %%sitename%%

    And see if the output is any better...

  7. RickRottman
    Member
    Posted 2 years ago #

    My Title template was already set to %%title%% - %%sitename%%.

  8. AG_Mike
    Member
    Posted 2 years ago #

    That seemed to do the trick. Thanks.

  9. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    @RickRottman: and it doesn't work?

    @AG_Mike: ok cool.

  10. RickRottman
    Member
    Posted 2 years ago #

    No, individual posts only have the post's title, not the site name.

  11. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Rick: and your sitename is not empty?

  12. RickRottman
    Member
    Posted 2 years ago #

    No, the site name appears everywhere else, just not on individual posts.

  13. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Mind sending me a login so I can have a look around? My email is joost @ my domain

  14. Ikkichi
    Member
    Posted 1 year ago #

    Hey All,

    Well I thought id ask a Question here since its on a similar subject.

    I have SEO by Yoast installed on my word press site. But I wanted to know how and if there's a way to make all the SEO wording be entered automatically from posts into the sections ?

    Thanks
    Ryan

  15. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Ikkichi, please next time open a new thread and don't hijack another one. The answer is no.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic