WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Anyone using photo galleries successfully with Yoast? (9 posts)

  1. nickaster
    Member
    Posted 1 year ago #

    I have found a bug in Yoast - if you have images (attachement) redirect to their parent post it seems to destroy photo essays (galleries). ie - if you click on a photo, it doesn't go to the photo page, but always reverts to the original gallery.

    Anyone manage to get galleries to work with Yoast?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. nickaster
    Member
    Posted 1 year ago #

    No one is using a gallery or two on their site here?

  3. nickaster
    Member
    Posted 1 year ago #

    Can someone at least tell me if this is *Supposed* to happen? or if I should be looking more deeply at things?

  4. kletskater
    Member
    Posted 1 year ago #

    I'am using WPPA and Simpleviewer, no problem with wp-SEO

  5. nickaster
    Member
    Posted 1 year ago #

    Interesting... I'm just using the default wordpress gallery code. Maybe I'll need some plugin? Curious if the default gallery code should cause a problem?

  6. kletskater
    Member
    Posted 1 year ago #

    Curious if the default gallery code should cause a problem?

    maybe Joost can help you with that one

  7. Social Chic
    Member
    Posted 1 year ago #

    I'm also using WPPA, no problem with WordPress SEO by Yoast. I mostly direct links off site.

  8. expertsolutions
    Member
    Posted 1 year ago #

    Yes. I had the same problem.

    Solution: Go to WordPress SEO> Permalink Settings>

    Then Uncheck Redirect attachment URL's to parent post URL.

    It must be ticked that's why it's keep going back..

  9. webeida
    Member
    Posted 1 year ago #

    Nickaster, I'm having the same problem as you. It seems that SEO by yoast gives all the images a permalink and prevents you from using the standard image link (i.e. http://yourdomain.com/image_folder/image.jpg).
    So what happens is:
    If you check "redirect attachment url to parent post url", and click on your picture in a post/page, it just reloads the post/page.
    If you uncheck "redirect attachment url to parent post url", and click on a picture in a post/page, it opens the image in its own url.
    Either option is a pain in the ass if all you want to do is have the image open in a lightbox on the page that it is found on.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.