WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] 310 error (6 posts)

  1. Samuel Aguilera
    Member
    Posted 2 years ago #

    If you activate the Permalinks -> Redirect attachment URL's to parent post URL. option and you have some attachments in the media library that has no parent post (i.e. are not uploaded from the post media library. images from an old migration for example).

    You will end with a lot of 310 apache errors (too many redirects).

    The plugin should check if the attachment has a parent post before doing the redirect to avoid this problem.

    Best regards.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Samuel Aguilera
    Member
    Posted 2 years ago #

    OK, fixed myself.

    If anyone needs it, do this:

    In the frontend/class-frontend.php file go to line 644 a you'll find this:

    if ( is_attachment() && isset($post->post_parent) && is_numeric($post->post_parent) ) {

    Leave it like this:

    if ( is_attachment() && isset($post->post_parent) && is_numeric($post->post_parent) && ($post->post_parent != 0) ) {

    And no more 310 errors when attachment has no parent post ;)

  3. luckygirrl
    Member
    Posted 2 years ago #

    hey i put a post here because im encountering a 310 error after changing my wordpress folder from 'blog' to 'community'
    I searched around and realized its not a browser issue.
    I just did a renaming from the directory housing wp from 'blog' to 'community'

    I did a search and replace in the database and files and fixed all direct links to the correct path.

    I also tried a plugin called Select Permalink Fix & Disable Canonical Redirects Pack Permalink Fix & Disable Canonical Redirects Pack
    but this did not help either

    I went through my wp-options in the db and also made changes where I saw they needed updating.

    here is what is in my htaccess file

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /community/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /community/index.php [L]
    </IfModule>

    # END WordPress

    What I am noticing is that when I type in the url http://www.stpbabes.com/community it redirects to http://www.stpbabes.com/community/welcome
    what is this welcome page and why is it doing this? I cant find it anywhere and don't understand why its trying to call it up instead of going to the index.php page.

    I can only view my site when I am logged in.

    Your help is appreciated!!

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    @Samuel: that'll be fixed in the next release.

    @Luckygirl: please open a new support thread, this has nothing to do with my plugin, for which this was a support thread.

  5. Samuel Aguilera
    Member
    Posted 2 years ago #

    @Joost: Thank you ;)

  6. Tyzing
    Member
    Posted 2 years ago #

    I think the OP's problem is what I'm facing but it's no longer at that line. So I'm still facing that 310 problem

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic