WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] 1.2.8.1 breaks admin (72 posts)

  1. polle001
    Member
    Posted 1 year ago #

    I just upgrade the plugin and now I have a blank admin in 2 sites.

    Another site loads in the admin but titles and metas are gone, also it seems the layout and translation is a mess. I will not update my other sites for now.

    Any way to fix and recover the 2 admin dead sites ?

    Thanks.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Do you have other plugins installed? I use WordPress SEO on a lot of sites and haven't see that.

    I would recommend deactivating all other plugins, activate WP SEO and see what happens. If it looks good, then activate all of the other plugins one by one. I'm just guessing here, but I think that there might be a conflict between plugins.

    If the other plugins are more important than the SEO one, maybe try the all in one SEO plugin?

  3. polle001
    Member
    Posted 1 year ago #

    Thanks Christine.

    Yes I have more plugins, I will test when I have the time to deactivate everything, which is not fun and time consuming. For the time I will stick to 1.2.7 which works fine and with no problems at all.

  4. Dan & Jennifer
    Member
    Posted 1 year ago #

    I'm seeing the same problem with the new version. 1.2.8.1.

    WordPress version: 3.4.1 (multisite)
    WordPress SEO version: 1.2.8.1

    I did this: updated the plugin - network activated the plugin

    I expected the plugin to do this: work as usual

    Instead it did this: broke admin access for all newly created sites on the network - we're also seeing some other weirdness that may be related wpconfig.php. Now getting errors with W3 Total Cache...

    this line disappeared FROM wp-config.php???
    define('WP_CACHE', true); // Added by W3 Total Cache

    I network deactivated 1.2.8.1 and the newly created sites' dashboards are functioning normally.

  5. Dan & Jennifer
    Member
    Posted 1 year ago #

    I disagree with deactivating all of our other plugins - this release is what created the conflict...

  6. Thanks for your input. Looking at the plugin home page, I see that others are having issues too. Hopefully Yoast gets back to you soon. He's usually very good and should come out with a fix.

  7. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

  8. pandorina
    Member
    Posted 1 year ago #

    It's not possible to set the meta tag for the home page. When I go to Title&Metatag -> Home the plugin redirect me to General tab.

  9. jtalk
    Member
    Posted 1 year ago #

    I have the same problem with 1.2.8.1. (Admin panel fails, with blanks)

    I need help, please.

  10. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

  11. jtalk
    Member
    Posted 1 year ago #

    My line 441 of wordpress-seo/admin/class-admin.php in new version 1.2.8.1 is:

    of update_option( 'wpseo', $options );

    But I have the same problem: admin panel of plugin with some blanks.

    ¿¿??

    Thanks!

  12. rrhobbs
    Member
    Posted 1 year ago #

    In addition to a nonfunctional admin panel (w 1.28), I have had problems with my sitemaps since the release of 1.28 - intermittently losing all sitemaps and / or losing the category / tags sitemeps (404) having implemented the 1.28 option fix, upgrading to the development version 1.28.1 and now currently back on 1.27. currently I have a functional sitemap_index.xml, posts and pages but the category / tags sitemaps throw 404's.

  13. JasonBC
    Member
    Posted 1 year ago #

    I experienced this same thing on a site this morning.

    This was my error:
    Fatal error: Call to undefined function update_options() in /data/s10/dom2262/httpdocs/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

  14. namreh
    Member
    Posted 1 year ago #

    I experience also some issues with 1.28.1

    - settingspages plugin without text labels
    - all my settings were removed
    - keep giving me the newversion-popup to confirm that I want tracking.

  15. csigncsign
    Member
    Posted 1 year ago #

    yes, have the same problem since the newest plugin update:

    WordPress version: 3.4.1 (multisite)
    WordPress SEO version: 1.2.8.1

    When activating WordPress Seo then I get

    Fatal error: Call to undefined function update_options() in /home/www/web246/html/sites/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

    Deactivating all other plugins is not a solution, the error remains.

    Any solutions?

  16. csigncsign
    Member
    Posted 1 year ago #

    ok, found the solution here http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-wordpress-seo-caused-my-site-to-display-just-white?replies=37 and works fine now:

    Go to the plugin's folder
    admin/class-admin.php
    and removed the "s" from update_options() on line 441

    line 441 must be so:

    update_option( 'wpseo', $options );

    now it works fine for me.

  17. namreh
    Member
    Posted 1 year ago #

    Ok, I found a solution for my adminerrors with the new version.

    I had my admin-area in Dutch and switched it to english and now all textlables are present again and the layout isn't fucked up anymore.

  18. theappwhisperer
    Member
    Posted 1 year ago #

    Both this and the earlier version are not working for me. It is such a pain. I have tried all the solutions above, such as deleting the 'S' etc but all to no avail. Can anyone help? I have no SEO options visible. I cannot access Stat Counter within the admin page and a host of other plugins. It's a disaster.

  19. ChrisCree
    Member
    Posted 1 year ago #

    @theappwhisperer the simple way to disable the plugin is to access your /wp-content/plugins/ directory via FTP or your hosting cPanel's File Manager and change the name of the /wordpress-seo/ folder to something else like /wordpress-seo-old/

    Doing so will disable the plugin so you can access everything else in your WP dashboard.

  20. theappwhisperer
    Member
    Posted 1 year ago #

    Hi, thank you for your comment, I can disable the plugin but I really like(d) it and want it to work. That's the problem.

  21. polle001
    Member
    Posted 1 year ago #

    People, just go back to 1.2.7 and done, everything works.

    1- Go to the plugin page and hit developers to get the older versions.
    2- Download 1.2.7.
    3- FTP to your site and go to the plugin directory.
    4- Download the xml file.
    5- Upload the 1.2.7 plugin directory replacing the one in the server.
    6- Upload the xml file replacing the one in the server.

    Done.

    Wait for 1.2.8.2.

  22. tradeonlineca
    Member
    Posted 1 year ago #

    I got the dreaded white screen in the admin panel but the site loaded ok. The most recent update was WordPress SEO so I assumed this maybe the problem. Followed this video http://yourwebsiteengineer.com/recover-from-the-wordpress-white-screen-of-death/ and disabled the plugin to get back to my admin panel. WordPress SEO version 1.2.8.1 works.

  23. MikeSunders
    Member
    Posted 1 year ago #

    Hi. I have the same theme and plugins in two sites.

    One is in english: http:/flybyrail.com

    The other in spanish: http://volarentren.com

    The admin of WordPress SEO works/look great on the site in english and broken on the spanish one.

    I guess this is strictly a problem regarding some CSS line lost in translation...

    Hope Joost fix it quickly!!

  24. minilobo
    Member
    Posted 1 year ago #

    My admin page is a mess too. It is in Spanish (my whole site is in Spanish)

    How can I change the admin page to English ?

    Updated:
    OK, I deleted "wordpress-seo-es_ES.mo" in the "languages" directory and now the admin menu is in English and works great. :)

  25. jtalk
    Member
    Posted 1 year ago #

    Fantastic!!! When I deleted wordpress-seo-es_ES.mo in languages directory of plugin vía FTP the admin menu works great. Now in english.

    But I will inform it...

    Thank You!!!

  26. digimind2011
    Member
    Posted 1 year ago #

    Can some one link the 1.2.8 version so I can downgrade is untill 1.2.8.2 is out??

    thanks u

  27. theappwhisperer
    Member
    Posted 1 year ago #

    I would love to go back to 1.2.7 as I've just installed the very latest version and still have the same problems. It was working perfectly before. I don't understand how to reinstall 1.2.7 using the method that Polle001 has recommended. I'm not that computer savy unfortunately ;(

  28. pandorina
    Member
    Posted 1 year ago #

    If you want, at this link you can download the version 1.2.7 ;)
    https://dl.dropbox.com/u/4904242/wordpress-seo%201.2.7.zip

  29. danetidwell
    Member
    Posted 1 year ago #

    This version killed my site, locking it up in Maintenance mode during the update.

  30. boah123
    Member
    Posted 1 year ago #

    The lasted version removes the buttons such as bold, italic, etc. from the content editor. When I deactivated the plugin the buttons are back, when I activate the plugin the buttons disappear.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic