WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WordPress Popular Posts] Slashes in WordPress Popular Posts (4 posts)

  1. Simon Wheatley
    Code for the People
    Posted 5 years ago #

    You need to strip slashes from your option values when you echo them into the admin screens, and again when you echo them for the actual widget and template tag. Try entering <h2 class="widget-title"> in "Before / after title:" to see the undesired effect currently. You can use the PHP function stripslashes.

    I would like it if you also allowed an option to use the default sidebar before/after title and before/after widget HTML, rather than having to specify it again in the options.

    http://wordpress.org/extend/plugins/wordpress-popular-posts/

  2. Héctor Cabrera
    Member
    Posted 5 years ago #

    Hi Simon,

    Another user reported this not long ago. The fix has been already included on the next version of WordPress Popular Posts (soon to be released).

    About the default markup issue, I've also taken care of that so don't worry ;)

  3. Gersprenz
    Member
    Posted 5 years ago #

    Hmm, this problem still exists with the acutal version.

  4. Héctor Cabrera
    Member
    Posted 5 years ago #

    Hi Gersprenz,

    Please download this file and replace the one you have in the wordpress-popular-posts directory. Then, go to your WordPress Popular Posts Administration Page, delete all backslashes and resubmit the form. You should find that the stray backslash goes away.

Topic Closed

This topic has been closed to new replies.

About this Topic