WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Popular Posts
No thumbnails after update, not pulling in first image (25 posts)

  1. Phil
    Member
    Posted 2 years ago #

    AFter updating the plugin, one of our sites no longer shows the thumbnails in the widget. All I get is the default 'no thumbnail' image.

    Does this plugin support the first image in post or is there another plugin that will do this?

    Phil

    http://wordpress.org/extend/plugins/wordpress-popular-posts/

  2. Phil
    Member
    Posted 2 years ago #

    I have attached a featured image which works, but we have thousands of posts and it is not practical to set a featured image on each one historically. Also, we have plenty of authors who submit posts without featured images - as previously the first image posted gets resized.

    I also notice that the thumbnail I just reset gets squashed - it doesn't keep the correct dimensions - unprofessional-looking, thus rendering this almost unusable unless theres a fix... =/

  3. Phil
    Member
    Posted 2 years ago #

    How come you didn't just use the latest version of timthumb from the developer?

    It has resolved the security issue and has been re-written to accommodate that.

  4. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    Hi PSM Digital,

    Thanks for your comments. I'm aware of all the issues that removing TimThumb have cause to some users of my plugin, and I apologize for that.

    While I understand your frustration about it, I believe you could be a little bit more polite when asking things. This plugin is a hobby of mine, and it's for free. No charges, gratis. No guarantees. All I'm asking for in return is people's constructive feedback in order to make my plugin better, not this.

  5. berlinrob
    Member
    Posted 2 years ago #

    Hello Hector,

    I have the same problem.

    After upgrading from version 2.1.4 to 2.2.1 I only see the "No Thumbnails" preview though I have a preview image attached to each article.

    How can I fix that?

    Thanks in advance,
    Robert

  6. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Robert,

    I'm already working on this. The new version of my plugin, right now under development, should take care of this for you automatically.

    However, right now the only solution is to assign a Featured Image to your popular posts so my plugin can pick it up and use it as a thumbnail.

  7. covermesongs
    Member
    Posted 2 years ago #

    Hi Hector,

    I too am having the issues above. I can't use a Featured Image at all (it messes up lots of other things with my theme), so anything that relies on that system is a nonstarter, and going back to 2.1.4 doesn't get a thumbnail anymore. I hope the next update allows the old system to work again (TimThumb I guess). I'd hate to lose such a great addition to my site.

  8. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    Hey,

    The problem I have with using third-party scripts (such as TimThumb) is that I need to keep monitoring them to make sure my plugin is running the latest version available. TimThumb is a great script, and I might re-add it again, however I'm trying to come up with a self-made solution that integrates well with my plugin.

  9. covermesongs
    Member
    Posted 2 years ago #

    Thanks for the reply Hector! I totally get what you're trying to do, but I bet I'm not the only one for whom automatically adding a Featured Image to every popular post doesn't work at all. Glad to know you're looking at it though and I look forward to the next version of WPP.

  10. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    I know. I wish there was a way to measure how many people actually uses it, and how they like it (or not) in order to decide what to do next.

    Hopefully, I'll find a workaround that will work for everyone as I'd really hate to go back to TimThumb.

    Thanks for understanding!

  11. jimmywhofan
    Member
    Posted 1 year ago #

    Any progress here? All I get is the "no thumbnail" image for all my posts? I would be willing to pay for something that works. Thanks!

  12. berlinrob
    Member
    Posted 1 year ago #

    @jimmywhofan: I just switched back to version 2.1.4, then everything works again.

  13. Héctor Cabrera
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys,

    Actually yes, I've been working on a test version of WPP and thumbnails are working nicely now. I'm testing it on my own site (cabrerahector.com) and so far I'm quite pleased with the results.

    If anyone is willing to test it and provide feedbacks please let me know and I'll post it here.

  14. thamjm
    Member
    Posted 1 year ago #

    Hi Hector,

    Yes please. If you could post it here, that will be marvellous. I am dying for it. Thank you very much.

  15. Héctor Cabrera
    Member
    Plugin Author

    Posted 1 year ago #

    Alright then, get it here and let me know how it works for you.

  16. Eugen Oprea
    Member
    Posted 1 year ago #

    The plugin works fine after you update to the latest version and select the source of your thumbnail.

  17. thamjm
    Member
    Posted 1 year ago #

    Hi Hector,
    Thank for the post. Unfortunately, it doesn't seem to work for me yet. However, I tweeted a bit with Get The Image Plugin to get the thumbnails. Thanks anyway.

  18. jimmywhofan
    Member
    Posted 1 year ago #

    thanks

  19. Héctor Cabrera
    Member
    Plugin Author

    Posted 1 year ago #

    @thamjm: I'd need to know more details about your site and how you configured the plugin to help you out.

    @everyone: please provide further feedbacks about WordPress Popular Posts' test version. If the feedback is positive, then I'll push an official update that includes other minor changes as well.

  20. chiefbief
    Member
    Posted 1 year ago #

    Hello Héctor,

    your test version seems to work ;-)

    Thank you for this nice plugin!!

  21. jellyroll4264
    Member
    Posted 1 year ago #

    Hi,

    The latest version does not seem to be working for me. I am getting a broken image. I have tried your suggestions from many other previous posts, but to no avail.

    If I wanted to try version 2.2.1 how would I install that?

    http://todaysbighit.com

    Thanks

  22. jellyroll4264
    Member
    Posted 1 year ago #

    I figured out how to go back to the old version. It is working for me now.

  23. lloollooll
    Member
    Posted 1 year ago #

    First word must be e BIG tanks for your excellent work.
    Now about the problem of not showing featured image, in my case problem is:
    Even if I go to options/popular post/tools and chose featured image then apply it wont make any difference because it always uses timthumb

    link of picture when featured is chosen:

    wp-content/plugins/wordpress-popular-posts/timthumb.php?src=http://mysite.com/wp-content/uploads/2012/10/ $imgname .jpg&h=90&w=90"thumbnail

    another thing about this new version when I went back to wordpress-popular-posts.2.2.1 started getting entry's on table wp_popularpostsdatacache field day_no_time 0000-00-00 so I can't go back to that version.

    Can't you sort this out I'm not developer or know anything about coding just tryng to fix my problem.

    Tanks

  24. Héctor Cabrera
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    Yes, the current official version still uses Timthumb to generate the thumbnails. The test version I linked above doesn't use Timthumb anymore as I've replaced it with Victor Teixeira's vt_resize function which seems to do the work quite well.

    About the day_no_time field, it won't affect previous versions of the plugin and will be used on future releases so I wouldn't worry about it.

  25. Jimmeh83
    Member
    Posted 1 year ago #

    Test version is working fine for me too, not sure if it will solve my 2.2.1 problems of inaccurate counters though. Comparing the numbers with google analytics shows some extremely contradictory information.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic