WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Popular Posts
[resolved] [Plugin: WordPress Popular Posts] Thumbnails not showing (15 posts)

  1. QuickBen
    Member
    Posted 3 years ago #

    I have WPP set up to show thumbnails in the widget. Until recently, the thumbnails of each post's featured image were showing correctly in the widget. However, now, they are not appearing at all. Just the broken image links appear.

    The only thing that I can think of doing recently was installing All-In-One-SEO Pack. Could this have caused the thumbnails to no longer appear?

    Any idea how I can get this fixed so that the thumbnails appear?

    Thank you!!
    Ben

  2. sublimity
    Member
    Posted 3 years ago #

    I have the same problem. Last night thumbnails were showing up just fine, and this morning they are not. I regenerated the thumbnails, didn't change anything.

    I am using WP 3.2, and it was working fine till this morning.

  3. richstrauss
    Member
    Posted 3 years ago #

    Same here, no thumbnails, cleared cache, regenerated, checked folder permissions... No thumbnails :(

    WP 3.2.1

  4. sublimity
    Member
    Posted 3 years ago #

    I'm also using WP 3.2.1 with the Canvas Woo Theme. I used their popular post tabs (Woo), then I opted to try wordpress popular post again--and for some reason it started working again. I have no idea why. I'm really at a loss and not even sure if I should continue to use the plugin for it may happen again.

  5. QuickBen
    Member
    Posted 3 years ago #

    So what's the deal?? I posted 6 days ago and no response from the creator of this plugin? Why am I not surprised?

    Anyone know of a premium plugin that will do "popular posts"? Commercial plugins tend to work better and have better support. I guess you get what you pay for...

  6. mikecav
    Member
    Posted 2 years ago #

    I'm also having this problem and would love to hear about a solution. Otherwise I'll just find another plugin.

  7. drwilson89
    Member
    Posted 2 years ago #

    Hi, Mikecav, I get the feeling that Hector the PopularPosts creator is working hard at this because his plugin is so popular. The issue of security is so great that it may be an industry-wide item. This happened around the same couple of days during which I was "herded" into upgrading my Microsoft Internet Explorer browser, and now some programs are firing off a Windows alert that the picture may be from a dangerous external source. I think that this may be because there is an industry-side agreement to embed certain identifiers into all pictures now and this has to be considered when doing editing of pictures.

    Maybe we will learn what is going on now at some time in the future.

    Myself, I can afford to use this period of "Missing Picture Link" on my blog as a time to remind people of the importance of Security, and of how we are all moving forward as efficiently as we can in a rapidly changing world. (While at the same time staying in a zone of feeling as safe as possible and not getting over-stressed.)

    I hope that soon we will get a message that there is a new update to this forum thread, telling us how to get thumbnails onto our PopularPosts plug-in.

    Unplugging now for a restful wind-down and sleep. Best wishes to all.

  8. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ben,

    Please read and follow the instructions I posted here.

    As a reminder, prior versions of my plugin relied on a script called TimThumb to generate the thumbnails. However, as drwilson89 pointed out, an exploit was found and the people at WordPress.org notified me about it so I had to take Timthumb out to keep your sites safe. Security is, in my opinion, more important so I hope you guys understand why I decided to alter that functionality.

    I'm currently working on WPP and fixing some other issues, an update should be coming soon. Meanwhile, please take a look at the link above in order to get your thumbnails back.

  9. mikecav
    Member
    Posted 2 years ago #

    Thank you both very much for the quick response and looking out for us!

  10. mikecav
    Member
    Posted 2 years ago #

    That didn't seem to work for me, but I can wait for an update. Didn't mean to come off as an ***hole in my previous post. Good to know it's being addressed. Thanks!

  11. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    No problem, Mike. No harm has been done.

    One thing I forgot to mention is that you need to reassign all thumbnails using the Featured Image function since it only works with new images.

    I'm already working on a workaround to allow users set the size of thumbnails from the widget interface (as it was before the last update) and I'm doing some testing now. If everything goes as expected I should be pushing an update soon.

  12. drwilson89
    Member
    Posted 2 years ago #

    Hello again. I saw this post about the thumbnail repair situation and have not yet seen an answer on another thread about the same topic. Is there a way for me to remove the timthumb identifier to thumbnails and allow the new arrangement to generate pictures?

    I have already made code changes, and reassigned a sample featured photo but the shadow/ghost of the thumbnail that is not showing still shows Properties that it was generated with Timthumb.

    I'm looking forward to the solution and as you can tell I'm very concerned about the new people who are visiting my site.

    At least I can someday tell "war stories" about cyber-security, etc., and the exorcism of TimThumb so that the ghost-pictures won't show up again like they are currently on my Popular Posts menu: http://naturalconnectionshealthcare.com/blog/ .

  13. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    The new version of WPP should fix that, drwilson. I should be pushing the update later today so keep an eye on your site's installed plugins page.

  14. drwilson89
    Member
    Posted 2 years ago #

    Perfect October/Halloween event, Héctor!

    You have exorcised the ghost of TimThumb and now my blog is restored to vibrant health. Thanks much.

    Take care, my friend, and enjoy the coming year-end and holiday season.

  15. Héctor Cabrera
    Member
    Plugin Author

    Posted 2 years ago #

    Glad to know that, my friend. Happy Halloween for you as well!

    A quick update for everyone: WPP has been updated to version 2.1.6 which addresses a few minor bugs and also re-adds the capability to manage thumbnails' width & height.

    The FAQ has also been updated with info about the usage of the thumbnails (and other stuff as well), so make sure you check it out.

    I'm changing this ticket to resolved. If anyone has any trouble please let me know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic