WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Plugin Kickstarter
Error Message upon activation (8 posts)

  1. aoirthoir
    Member
    Posted 2 years ago #

    At activation we get the following message:

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in /path.to.wordpress/wp-content/plugins/wordpress-plugin-kickstarter/model/model.php on line 314

    http://wordpress.org/extend/plugins/wordpress-plugin-kickstarter/

  2. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi aoirthoir,
    This is because I'm using PHP 5.3 and previous does not allow to call static method as variable which holds the method's name:
    $content = $parts[0]::$parts[1]();

    What do you think, do I need to rewrite this code to be compatible with PHP lower then 5.3?

    Regards,

  3. aoirthoir
    Member
    Posted 2 years ago #

    Vasyl,

    I just checked and Dreamhost is running 5.2.17. Since they run a LOT of sites I might suggest that holding off for 5.3 would be a good idea.

    The idea of static functions though is great and gives a lot of power to a system.

    However, my goal typically is to make my plugins php5 and mysql5 compatible at the base version. Only when a point version becomes ubiquitous would I use the additional features.

    Definitely interested in collaborating with you.

  4. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Yeap, you are right. Most of web hostings provide 5.2 PHP version. But the code, generated by kickstarter, is compatible from 5.0.
    Probably I'll just rewrite kickstarter to be useful and for 5.2.
    Thanks for feedback

  5. aoirthoir
    Member
    Posted 2 years ago #

    Excellent.

    Based on some ideas I have, we could create this in such a way that the entire code base output could be the will of the user. Then instead of us determining how the code is output, they do. It could allow for saving patterns which they could then distribute. ...definitely a conversation worth having.

  6. EllsWeb
    Member
    Posted 2 years ago #

    I was wondering, is there any plan to update this plugin for WP 3.3.1?

  7. WP AAM
    Member
    Plugin Author

    Posted 2 years ago #

    Hi ellsweb,
    I can't get your question. What does it mean for you "update this plugin for WP 3.3.1"?
    This is plugin kickstarter and doesn't depend of WordPress version.

    Regards,
    Vasyl

  8. EllsWeb
    Member
    Posted 2 years ago #

    Sorry for the misunderstanding.
    I thought plugin development did take into consideration the version of WP. My error..

    Might you consider updating the information with WP so those of us less informed about the actual working of your plugin won't wonder about that?

    I just didn't see when I looked at your plugin that it had nothing to do with the version of WP or that it doesn't depend on WP version.. And any plugin created by your plugin doesn't have to be concerned about the current hooks and deprecated calls.. Thanks for the clarification.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic