WordPress.org

Ready to get started?Download WordPress

Forums

WordPress plugin - Google +1 Button
[resolved] [Plugin: WordPress plugin - Google +1 Button] Bug in script - Resolution - please fix in source (3 posts)

  1. ilikewp
    Member
    Posted 3 years ago #

    Hi,

    there is a bug in your script, causing several errors. In my case, the whole site gets white in Internet Explorer, so the content can't be seen.

    In googleplusone.php in lines 331, 349, 353, 384 and 401 you're working with the variable $count.
    But you're using it as a boolean value ($count=true) instead of a string ($count="true"), so when echoing the plusone-button (lines 360 and 405), the value of the plusone-attribute "count" is empty, which seems to be the worst thing, Googles +1-JavaScript could ever happen.

    Defining the $count-values as a string, everything is fine.

    I would appreciate, if you gonna fix the plugin.

    Thanks a lot

    Phil

    http://wordpress.org/extend/plugins/google-plus-one-google1/

  2. ilikewp
    Member
    Posted 3 years ago #

    Additionally, I would suggest to recreate the initialization of the plusone-button according to this site: http://www.gabsoftware.com/tips/load-google-plus-one-button-asynchronously/

    Implementing this code, I had no white pages anymore on any site.
    Now everything is working like a charme.

    Phil

  3. beggers
    Member
    Posted 2 years ago #

    Have these changes been implemented?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic