WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WordPress MU Sitewide Tags Pages] Works with sub.domain.com? (9 posts)

  1. russiantranslator
    Member
    Posted 5 years ago #

    Hello,
    It seems like a great plugin but I could not make it work on my WPMU website that uses subdomains? Is it possible?

    http://wordpress.org/extend/plugins/wordpress-mu-sitewide-tags/

  2. @mercime
    Volunteer Moderator
    Posted 5 years ago #

  3. Trent Adams
    Member
    Posted 5 years ago #

    I have it working with subdomains just fine. I am not sure if it works with subdirectories though as I have never tried it or know anyone that has.

    Trent

  4. @mercime
    Volunteer Moderator
    Posted 5 years ago #

    It works with both subdirectories and subdomains.

  5. Joss Winn
    Member
    Posted 5 years ago #

    I've just installed this. It created the 'tags' blog but it's empty:
    http://learninglab.lincoln.ac.uk/blogs/tags/

    and the 'Enabled' checkbox on the options page is unchecked after saving it as checked.

    Any advice on resolving this is much appreciated.
    Thanks
    Joss

  6. Joss Winn
    Member
    Posted 5 years ago #

    Ah, OK. It only shows tags from blogs created after the plugin has been installed.

  7. davemoyer
    Member
    Posted 5 years ago #

    Josswinn,

    The "phantom checkbox" problem is quite common seeing as it's a bug in the plugin! Thankfully it was a simple one, and a 30 second fix. I've emailed Donncha so hopefully it'll be fixed soon.

    After having the same problem myself, I figured out that it was a simple bug in the plugin causing the issue. Here's all you need to do to solve the issue.

    Line 40 of sitewide-tags.php has an if() line in it telling the plugin to output a certain code if it's enabled. This code will make the checkbox checked! However, rather than outputting the correct code, 'checked="checked"', it was simply outputting 'checked'. Just copy and paste in a new line 40:

    <label><input name="tags_blog_enabled" type="checkbox" id="tags_blog_enabled" value="1" <?php if( get_site_option( 'tags_blog_enabled', 0 ) == 1 ) { echo 'checked="checked"'; } ?>" /> <strong><?php _e("Enabled","wpmu-sitewide-tags"); ?></strong></label><br />

    And things should work just fine. Tell your friends ;)

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Thanks Dave. The "checked" code always worked for me in Firefox but I've changed the plugin now if you want to download the development version to test it.

  9. Umbrovskis.com
    Member
    Posted 5 years ago #

    look like is not working on WPMU 2.7.x even with changes mentioned by @davemoyer
    Still can't get tags.mywpmu.xxx to show sitewide tags
    :(

Topic Closed

This topic has been closed to new replies.

About this Topic