WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Sitewide Tags Pages
[resolved] Make posts show under main site cats? (15 posts)

  1. charliebrimm
    Member
    Posted 2 years ago #

    The plugin is grabbing posts from all other blogs on the network and listing on the main blog. That is good.

    Is there a way to list the cats for the main blog so that it pulls all posts from the network?

    For example: If I click on Cars cat on the main blog can I get it to show posts from all blogs that have the cat Cars?

    How would this be done?

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-mu-sitewide-tags/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    How would this be done?

    That's what SWT does already.

  3. charliebrimm
    Member
    Posted 2 years ago #

    That's what I figured. I was trying to figure out why it was not working properly so I switched to 2011 theme and there it was. The culprit was the custom theme. It was using switch_to_blog() to switch to the tags blog for the main site.

    So this was building the main page from the posts in the tag blog but the cats were being built differently.

    This got a little screwy ticking the box for add posts to main blog with a separate tags blog being used in config.

    After I ticked the box to add posts to the main site and the posts stopped adding to the tags blog. Is this standard behavior or could be the custom theme?

    In config it says: You can create your post archive in a specific 'tags' blog of your choosing, or you can use the main blog of your site. Each has it's own pros and cons.

    Is there somewhere those pros and cons are listed? I am trying to figure out the best way to fulfill our needs.

    Thanks for your time and help.

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    After I ticked the box to add posts to the main site and the posts stopped adding to the tags blog. Is this standard behavior or could be the custom theme?

    Standard behavior. By ticking the box you are saying the main site is the tags blog.

  5. charliebrimm
    Member
    Posted 2 years ago #

    Ok. So at that point it doesn't really matter if the tags blog is defined or not because it is no longer being used?

    If the box is not ticked I'm assuming that the tags blog is doing redirects to the main blog?

    Can you explain or point me to what the pros and cons are of using a tags blog or the main site? I see that one is that the main blog becomes an archive and not it's own blog anymore.

    I'm working with a network that was built by someone else and didn't meet all of the requirements.

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    If the box is not ticked I'm assuming that the tags blog is doing redirects to the main blog?

    No, there are no redirects. Posts written on the main blog are added to the tags blog. Those ones have the permalink to the original post just like any other blog.

    Can you explain or point me to what the pros and cons are of using a tags blog or the main site?

    Are you using the main site to post original content (ie. non SWT aggregated content)? If you are then you may not want both the aggregated content and original content in the same site. Typically I think most people using the main site for the tags blog post very little original content there.

  7. Jason
    Member
    Posted 2 years ago #

    Ok, You just made it clear indirectly what the pro/cons are.

    These are pulling posts as if they are the the selected blog's posts. (main or not)

    If it's on the main blog, it'll make a mess of your blog posts (WHich it has on mine)

    I made a site menu that only shows posts from a "Mainblog" category, however, if a subsite makes a category with that name, then they COULD post into it if they figured that out.

    That helps me a lot actually, thanks!

  8. joedepo
    Member
    Posted 1 year ago #

    I am actually experiencing similar issues. I don't know why the posts are not populating from other blogs. If someone creates a blog lets say mydomain.com/newblog it will not post to my main site. however if they are just registered and create a random post under a certain category it will. maybe you can help me since you seem like you've experienced a similar issue.

  9. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    @joedepo - did you install in the mu-plugins folder, network activate or activate on the main site?

  10. joedepo
    Member
    Posted 1 year ago #

    i installed it in normal plugs folder, and then activated it on my site, and i went to network dashboard/plugins and clicked network activate

    do i need to seperatley install it in a mu-plugins folder? or did i do the right steps?

  11. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    You didn't need to activate it on the main site. It just needs to be network activated or in the mu-plugins folder.

    What is the privacy setting on your sub sites?

  12. joedepo
    Member
    Posted 1 year ago #

    okay i uninstalled it updated the network and then reinstalled the plugin and only netork activated it. my privacy setting for sub site was set to public. but how do i check? in case in the plugin i enabled private sites as well though.

  13. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Are you saying the posts don't appear in the admin area or that they don't appear on the front end of the site?

  14. joedepo
    Member
    Posted 1 year ago #

    they dont appear on the front end of my site

  15. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Are they in the admin area? If so, then you'll have to look at your theme and see why they are not being displayed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic