WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
[resolved] The requested URL was not found (5 posts)

  1. faqnet
    Member
    Posted 3 years ago #

    hey guys
    my domain mapping is not working correctly

    I followed Otto's manual and was able to get the TLDs working but internal pages of mapped domains are "not found"

    my main site:
    http://faq-network.com/
    http://faq-network.com/blog/2010/11/08/hello-world/
    is working fine...

    my mapped domain #1:
    http://faq-network.com/playhelpnet/ - ok
    http://playhelp.net/ - ok
    http://playhelp.net/2010/11/08/thats-a-new-post/ - 404 error

    my mapped domain #2:
    http://faq-network.com/tophowtoscom/ - ok
    http://tophowtos.com/ - ok
    http://tophowtos.com/2010/11/08/test/ - 404 error
    http://tophowtos.com/2010/11/08/hello-world/ - 404 error

    I doublechecked all install steps and I think I didn't skip anything
    any clue what might may be wrong?
    thanks

  2. Go into the admin area of one of the mapped bogs and resave the permalinks.

  3. faqnet
    Member
    Posted 3 years ago #

    Thanks for your reply Andrea

    the internal pages work fine when I change the permaling structure to /?p=123

    I tried resaving permalinks ("Permalink structure updated."), switched it back and forth and "nice" permalinks don't seem to work while /?p=123 permalinks work fine

    I found someone else with exactly the same problem:
    http://ocaoimh.ie/wordpress-mu-domain-mapping-05/comment-page-1/#comment-670442
    ...and for him permalink format /?p=123 also works fine

    my .htaccess file is writable and goes like this:
    cat .htaccess

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  4. faqnet
    Member
    Posted 3 years ago #

    here's a mapped working one (only with default permalink structure):
    http://askhowto.org/?p=1

    and this one doesn't work:
    http://tophowtos.com/2010/11/08/hello-world/

  5. faqnet
    Member
    Posted 3 years ago #

    Ok, solution found
    All to-be-mapped domains were caught by default Apache setting which had no "AllowOverride All" directive for my wordpress directory
    Just as for this dude here:
    http://wpmututorials.com/basics/everything-you-wanted-to-know-about-creating-a-network-of-multiple-sites-in-3-0/#comment-9906

    Andrea, thanks for pointing me in the right direction
    Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic