WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
[closed] Sunrise.php Error > Other Domains Not Working (11 posts)

  1. Jeremy Ashburn
    Member
    Posted 3 years ago #

    I get the below error when clicking Domains or Domain Mapping from the Super Admin Menu. I've tried moving sunrise.php around in my wp-config.php and still can't fix it. My main site is working but other domains (which are using the plugin) aren't working.

    Please edit your /home/jeremy/public_html/wp-config.php and move the line define( 'SUNRISE', 'on' ); above the last require_once() in that file or make sure you updated sunrise.php.

    Jeremy Ashburn
    jeremyashburn at yahoo dot com

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Did you also put the sunrise.php file in the wp-content/ folder as instructed?

  3. probablepossible
    Member
    Posted 3 years ago #

    I have the same error message since yesterday when I upgraded to 3.5.

    Sunrise.php is in the wp-content/ directory, and the plugin is at the most current version

  4. So you just upgraded WP?

    Might have to upgrade to the dev version of the plugin.

  5. probablepossible
    Member
    Posted 3 years ago #

    Actually, I just entered the new domain directly into the table in mysql. Worked fine...

    I'll wait on the next version.

  6. Jeremy Ashburn
    Member
    Posted 3 years ago #

    Yeah. Try the dev version. I haven't had any issues.

  7. Still didn't answer the question. ;)

    Were you using domain mapping before you upgraded? And if so, did it work?

  8. probablepossible
    Member
    Posted 3 years ago #

    WELLL!

    as it turned out, although the mu-plugins directory as in the contents directory, the domain_mapping.php file wasn't in it.

    (And i don't know why it wasn't because I had mapped three domains previously with no problem.)

    So my guess is that "where is your domain_mapping.php located?" would be a question to ask when this error comes up. *blush*

  9. probablepossible
    Member
    Posted 3 years ago #

    dammit, except that didn't make any difference...

  10. Crap, this means I'm gonna have to go test it... :D

  11. probablepossible
    Member
    Posted 3 years ago #

    I just installed it on another wordpress site on the same server with the same configs, and it's working perfectly...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic