WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
ssl and mapped domain (2 posts)

  1. pablo
    Member
    Posted 3 years ago #

    Hello.
    I have a multisite multidomain wordpress installed on a basedomain.net. The central blog is calle baseblog.

    Of course I use dommain mapping plugin, and basedomain.net is an Aname to other centralserverdomain.net in my dns.
    So I configure domain mapping to point like a Cname to basedomain.net

    I have myblog (blog_id 2) mapped to mydomain.net through the blogadmin panel of this blog.

    And all is working ok. Well, I have a doubt,I'm not sure if I have to change the fields in the SuperAdmin>Sites>Edit page for the blog mapped.
    If I put
    Domain: mydomain.net
    Path: /
    (and below) SiteURL: http://mydomain.net
    all works. And I a maintain the original values:
    Domain: basedomain.net
    Path: /myblog/
    (and below) SiteURL: http://basedomain.net/myblog

    All works the same, or I can not see any difference.

    But when I enable ssl activating 'define ( 'FORCE_SSL_ADMIN', true);' in wp-config.php the things get a bit complicated for the mapped blog. The folder blogs in the basedomain works without any problem.

    ssl works very well in the mapped domain, but when I upload a file its links become htttps, so I endup surfing my no-ssl web (my http 80 non-protected site) getting images, pdf and any other stuff through a ssl connection. The permalink shown under the title when editing a post is https://....

    I don't want that, is cpu-expensive and is slow downing my page.

    Of course I can edit de html post and put out the 's' ohf https, but is no fun.
    I forgot to say I have the same rules in my 80 and my 443 virtual host.

    So I want to know if this is a desirable effect on ssl mode or I have a missconfiguration, a bug ...

    And if i'm not making a mistake, do you think is possible to disable this behavior modifying slightly (I'm not a programmer) a php file (from plugin or core), or creating a rewrite rule?

    Thanks for your help.
    pablo

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. fraggeln
    Member
    Posted 2 years ago #

    This needs bumping.
    I have the same problem.
    Does anyone know how to fix it?

    Regards
    F

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic