WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
my mapped domain is going to a default apache CGI page (8 posts)

  1. SiteSubscribe
    Member
    Posted 3 years ago #

    For some reason my mapped domain (busproplus.com) is going to a default apache CGI page.

    Here are the steps that I've taken:
    -cpanel: verified that A record for primary domain sitespiration.com pointing to IP of my VPS already exists
    -cpanel: created A record for *.sitespiration.com (root site)
    -cpanel: parked the domain to be mapped (busproplus.com), with no redirect
    -ftp: loaded domain_mapping.php into mu-plugins dir
    -ftp: loaded sunrise.php into wp-content dir
    -ftp: updated wp-config to enable sunrise
    -WP admin (network): "Domain Mapping" -> added IP address for VPS
    -WP admin (network): "Domains" -> added blog ID and domain map
    -WP admin (network): "Sites" shows blog domain mapped properly
    -WP admin (blog): "Domain Mapping" -> shows blog domain mapped properly

    What am I missing?

    For some reason my mapped domain (busproplus.com) is still going to a default apache CGI page:
    http://busproplus.com/cgi-sys/defaultwebpage.cgi

    Any ideas?

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    If you have plesk you need to make the mapped domain an alias to your WP install. If you have cPanel, you need to park the mapped domain on the WP install.

    With either of those control panels I've seen times where they don't restart the webserver which is needed for the configuration changes to take effect.

  3. -cpanel: parked the domain to be mapped (busproplus.com), with no redirect

    Did you park it on the domain for the main site/install?

  4. SiteSubscribe
    Member
    Posted 3 years ago #

    Thanks for the quick replies!

    I just restarted the server. Same result.

    "Did you park it on the domain for the main site/install?"
    I think so...

    I had previously parked the domain for the domain I'm trying to map (within cpanel of the wp install for the site root); I did not redirect it to anything, so it should be pointing to the root site.

    So I have busproplus.com parked within cpanel for sitespiration.com, which is the domain for the main site/install (which created an A record pointing to the IP of the server).

    I can get to http://sitespiration.com/busproplus/wp-admin/

    But when I 'view site' it goes to:
    http://busproplus.com/cgi-sys/defaultwebpage.cgi

    I just tried redirecting the parked domain within cpanel to http://sitespiration.com (the main site/install). Then I restarted the server. Same result.

  5. SiteSubscribe
    Member
    Posted 3 years ago #

    I think it may be solved now (still testing to be sure).

    It seems that the DNS on my computer needed to be flushed (and browser cache, again) so that the correct page would display.

    Thanks very much for your help.

    Is there a difference or benefit between the 2 domain mapping plugins?

    #1)
    wordpress-mu-domain-mapping
    http://ocaoimh.ie/wordpress-mu-domain-mapping/

    #2)
    Domain Mapping (VHOST and directory enabled Domain Mapping plugin)
    http://premium.wpmudev.org/project/domain-mapping

  6. drokkon
    Member
    Posted 3 years ago #

    I have a similar problem and was wondering if someone could help me out.

    1. mainMUsite.com and subMUsite.com (example names) are both purchased through 1and1. I have an A record for both pointing them to the IP address of my VPS (VPSLatch.com).

    2. At VPSLatch, I have a WHM login, and I created a user for the mainMUsite.com site, where I installed the WordPress Multisite.

    3. In Multisite, I created a subsite: http://mainMUsite.com/subMUsite.com and installed this plugin.

    4. I thought it would work as is, but I'm just getting the Apache page too. I tried to park subMUsite.com on top of mainMUsite.com using my cPanel account for mainMUsite.com, but it wouldn't let me. (Error from park wrapper: Using nameservers with the following IPs: 74.208.3.7,74.208.2.8 Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.) However, when I parked subMUsite.com on top of mainMUsite.com using the main WHM account, it DID let me.

    Unfortunately, the plugin still isn't working. I have a very rudimentary knowledge of this whole DNS thing that I'm trying to flesh out.

    Thanks!

  7. drokkon
    Member
    Posted 3 years ago #

    Scratch that...as usual, it started working immediately after posting. However, if I HAVE done something incorrectly, feel free to point it out.

  8. drokkon
    Member
    Posted 3 years ago #

    Okay, perhaps someone can help me after all.

    I was having trouble running a relatively complicated plugin (Gantry by Rockettheme) and it turned out that this domain mapping plugin was causing it to choke. After disabling this plugin, the domains still appear to be mapped!

    What's going on? I'm considering leaving it disabled so that I can continue to use Gantry, but I'm worried because I don't understand what's going on.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic