WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
multi domain setup - login issues (11 posts)

  1. searchmaster
    Member
    Posted 3 years ago #

    I have successfully parked a number of domains on top of the main website. Then used the mu domain mapping functionality and it all works fine - sort of.

    When I try and logon to the individual websites, with wp-config.php subdomain_install=true, I can't logon. But with it =false, I am able to logon. However, links to inner pages from the live site don't work. So I immediately change it back to true, and continue to be able to access wp-admin of the site.

    It is a pain having to turn the subdomain_install=false every time I want to logon. Where am I going wrong in my setup for this to happen? How do I fix it?

    In addition, I have to manually add non www to www redirects into the htaccess of the site. The main domain used in traditional wp installs automatically does such a redirect, such requirement for htaccess should not be needed for the mu plugin.

    I first add the site as a subdomain, then manually change the setup url's to the proper full domain. Is there any way of being able to add the proper domain the first time, and so not have to go through the subdomain then rewrite to proper domain routine?

  2. I first add the site as a subdomain, then manually change the setup url's to the proper full domain.

    This is the problem.

    If you're using the domain mapping plugin, then use the domain mapping menus to actually change the URL for the sub-blogs. Do not manually edit the site to change the URL, this is why it's not working.

    http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

  3. searchmaster
    Member
    Posted 3 years ago #

    Thanks for your insight!

    To clarify:
    - master site setup for subdomains
    - 'a' records for the main site setup as wildcard *.domain.com
    - add site so that it shows as sub.domain.com
    - go to superadmin domains, and add in that sites id, and its proper domain name http://www.sub.com.
    - then you can see on the superadmin sites, the subdomain, and its mapping to the proper domain name

    ???
    Then you should be able to access http://www.sub.com directly?
    and have the non www version sub.com redirect automatically to http://www.sub.com?
    and access http://www.sub/wp-admin/

  4. searchmaster
    Member
    Posted 3 years ago #

    Currently, when I access:
    sub.com, I get redirected to http://www.domain.com/wp-signup.php?new=sub.com
    - it should redirect to http://www.sub.com and show a wordpress site

    http://www.sub.com - gets redirected to sub.domain.com - either a 302 or 301 redirect depending on the ticking of the "permanent redirect"
    - and it shows the text "apache working correctly"
    - it should show the wordpress site

    Not sure what I am doing wrong.

  5. Did you park sub.com on your web host account? Gotta tell the server to answer for it.

  6. searchmaster
    Member
    Posted 3 years ago #

    Nicelyparked. That is why it is able to redirect at all, otherwise it would not be found.

    Thanks for your responses. Love for this to be fixed.

  7. It's nothing that can be fixed in the plugin - it's all on your end.
    Go to the backend of sub.domain.com, to Tools -Domain Mapping. Check the "primary domain" box.

  8. fencepost
    Member
    Posted 3 years ago #

    I was just dealing with what I think is this exact thing, and I also ended up editing the URLs under Super Admin / Sites / (edit link for individual site). This is because when adding a new site, it defaults to adding newsite.masterdomain.com, but because in cPanel I added them as Parked domains with no redirection, those addresses don't seem to exist.

    This may be an issue on my end with the wildcard DNS entry I added in WHM - in theory it should be resolving *.masterdomain.com, and it does seem to be doing so, but what I was getting was the Apache/WHM/cPanel working correctly pages.

    Am I missing something?

  9. fencepost
    Member
    Posted 3 years ago #

    Thinking further on this, it may be configured that way because the various hosting plans at my provider have varying numbers of "addon" domains - they aren't able to host unlimited domains, so the wildcard may not be operating the way it would on an unrestricted hosting setup (or self-hosting).

    In this configuration it may be necessary to do this kind of editing, or at least to configure each subdomain or addon/parked domain in cPanel as well.

  10. The wildcard subdomain entry has nothing to do with domain mapping. really.

    If you're parking domains in Cpaenl, they default to the main domain of the account. that *must* be the one where you have wordpress installed & multistie enabled.

  11. searchmaster
    Member
    Posted 3 years ago #

    Go to the backend of sub.domain.com, to Tools -Domain Mapping. Check the "primary domain" box.

    Yippeeee. That was the missing ingredient.

    Its now working

    Thanks Andrea. Most appreciated!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic