WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
MU mapping domain broke redirect only in main site (8 posts)

  1. enrican1976
    Member
    Posted 3 years ago #

    Hi to all,

    This plugin work very good, I have only problem that it broke registration redirect in main blog.

    The strange thing is that in all subdomains registration redirect work.

    I use the plugin for redirect:

    BP Auto Activate Autologin Redirect To Profile On Signup

    I have installed WPMU 3.1.2 in subdomains and BP 1.2.8

    You can try registration in two subdomains of this installation:

    http://www.premonitionbook.com (MU mapping domain configured that redirect to this site)

    test1.higringo.com (MU mapping domain configured that redirect to subdomain)

    It seem that MU mapping domain don't map the main site http://www.higringo.com

    I understend that I have to add alias on server for subdomains like premonitionbook.higringo.com that have redirection to domain http://www.premonitionbook.com

    But I don't understend why I have to add alias for subdomains like test1.higringo.com that don't have associated any domain.

    And only if I add the alias they work.

    Some ideas?

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    It seem that MU mapping domain don't map the main site http://www.higringo.com

    You cannot domain map to the main site. The DM plugin does not permit this because it creates other issues with the network.

    But I don't understend why I have to add alias for subdomains like test1.higringo.com that don't have associated any domain.

    If you set up wildcard subdomains in your DNS and in your webserver config for your install's domain then you won't need to add aliases for each subdomain.

    I'm not familiar with the BP autoredirect plugin so you'll have to sort that one out on your own.

  3. enrican1976
    Member
    Posted 3 years ago #

    Dear Ron,

    Thank for your answer.

    I set both on DNS and SERVER too. How have to be setted subdomains without a domain on MU domain mapping?

    Primary or not primary?

    es: test1.higirngo.com have alias (work)
    es: test2.higringo.com don't have alias (don't work)

    Many Thank

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    If you have a folder install then you need to use domain mapping to map the subdomains in WP.

    If you have a subdomain install you can create those through the network admin create site screen.

  5. enrican1976
    Member
    Posted 3 years ago #

    Hi Ron,

    Thank again for your explanation.

    I check and was find that MU mapping domain is not compatible with Transposh (fantastic multilanguage plugin that I need in my blog) I was find another multilanguage plugin (WPML) but creators said that is not compatible too with MU mapping domain.

    Moreover if I map subdomains for example test1.higringo.com to test1.higringo.com setted as primary (naturally after I need to insert on server the alias test1.higringo.com) the redirect after registration work.

    So in my scenario all blogs work apart main blog becouse is not mapped.

    I try to force in MU Mapping Domain the insert manually of one record with the mapping of main blog http://www.higringo.com to domain http://www.higringo.com with blog ID 1 and primary actived but whitout success.

    I think a lot of people need to have multilanguage on WPMU and can be easy for very genius programmer like you to find a quik work around for this problem :)

    Please help me.

    Now Ofer, the developer of Transposh is looking to help me fixing the problem in him plugin. If he isn't able, please try to give me you the solution.

    Thank in advance to you and Andrea for your work.

    Cantori Enrico

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 3 years ago #

    I think a lot of people need to have multilanguage on WPMU and can be easy for very genius programmer like you to find a quik work around for this problem :)

    I've never worked with any of the multilingual programs but I do know they are complicated enough that I wouldn't be able to come up with a quick fix for the issue.

  7. enrican1976
    Member
    Posted 3 years ago #

    You have true.

    What you think if I change main blog from http://www.higringo.com to for example blog.higringo.com and try to map manually on DB and add an alias on server?

    Another way is to use main domain not for registration but only like a mask for my sites.

    Both way work with the use on server of alias for each blog.

    Any suggest?

  8. John
    Member
    Posted 2 years ago #

    I'm having a somewhat related issue.
    I just converted my site to MU, maindomain.com
    my old site was maindomain.net

    Everything seams to be working great, maindomain.net is an aliases of maindomain.com so visitor are re-directed to the new site. The problem i am having is that my old feed is now broken. maindomain.net/feed redirects to the homepage of the new site. So RSS readers are just considering the feed broken. Is there a way to force that old url to spit out the feed?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic