WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
Issues with Cookies (2 posts)

  1. treccase
    Member
    Posted 2 years ago #

    Hi,

    I used the plugin on a new 3.3, (works fine on my 3.21 install) and all heck broke lose. 3 domains (1 main non parked). One domain wont let me login as admin, says my cookies not set (they are). The second domain just assumes every visitor is the super admin of the network, and when i logout .. i am still logged in. WordPress logs has errors all over such as:

    [16-Dec-2011 09:50:34] PHP Notice: Undefined index: HTTP_HOST in /var/www/wordpress/wp-content/sunrise.php on line 11
    [16-Dec-2011 09:50:34] PHP Notice: Undefined index: HTTP_HOST in /var/www/wordpress/wp-includes/ms-settings.php on line 25
    [16-Dec-2011 10:01:19] PHP Notice: Undefined property: stdClass::$site_name in /var/www/wordpress/wp-login.php on line 85

    Now if I re-install plugin I also get error (((The plugin generated 140 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin. ... ))) This wasn't the case in the beginning.

    I also am unable to change anything in [settings>domain mapping] page (four bottom check marks are always on) and neither IP nor domain on that page saves.

    Besides that all looks alright. I just wanna know if its the 3.3 or the nginx I am using for first time since all is well on my 3.21 MU on apache.

    thanks, i am sure I am screwing up somewhere but this is my 3rd reinstall with same results.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    If HTTP_HOST isn't set then your PHP setup for nginx is not set up correctly.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic