WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
Going to the homepage and not the sub dir blog (16 posts)

  1. L-Creep
    Member
    Posted 3 years ago #

    I have the latest version of WP installed and have tried to set this up. Everything looked in order with regards to accessing the backend of the blogs and also looking at the sub dir blogs by visiting the URL to them directly, however....

    When I go to the URL that is supposed to be redirected I am taken to the homepage of the blog which has this plugin installed on and the URL in the navigation bar changes to the homepage of the main site.

    Does anyone have any pointers on this?

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Added links to that post in the readme, thanks Andrea (and Otto!)

  3. mayday
    Member
    Posted 3 years ago #

    I have the same issue, that I have followed the domain mapping and WP setup to the letter several times, and my mapped url goes to the main sites home page, not the mapped url. Tony Zeoli kindly tried to help me figure out the problem over at http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/

    I can't make this work and I desparately need to! I would appreciate any help.

    Robert

  4. mayday
    Member
    Posted 3 years ago #

    Anybody have any thoughts?

  5. mayday
    Member
    Posted 3 years ago #

    No help here.

  6. Can you outline, exactly, every single step you DID do?

    Becasue if it's redirected, you missed something.

  7. mayday
    Member
    Posted 3 years ago #

    Hello! I have the plugin installed and working on a fresh install of WP3.01. sunrise.php in wp-content folder and domain-mapping.php in mu-plugins folder, added define( 'SUNRISE', 'on' ); to wp-config, have domain mapping under SuperAdmin and have added a second site.

    I want site2 to have its own url, owhrep.com, resolve to owhfarm.com/rep. I host at MT on a dv and have set the dns to the correct IP address. Using Plesk, I created a new site for owhrep.com and forwarded it to owhfarm.com
    When I browse to owhrep.com it doesn’t map to the directory, instead to owhfarm.com
    Domain mapping in the backend of site2 has Primary domain set to owhrep.com

    It is forwarding but not rewriting the url to the subdirectory.

  8. mayday
    Member
    Posted 3 years ago #

    Here is the total contents of my .htaccess:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
  9. You need the Media-temple specific directions.

    Since you;re not using cpanel, you can't "park" the domain. Use plesk to make a Server Alias, not a forwarder. that's part of the reason.

  10. mayday
    Member
    Posted 3 years ago #

    OK!! I want to report back here the solution I found. :)

    Since I host at MediaTemple and use Plesk there are issues about how Plesk handles domain names. Essentially, when you point the dns to a server that hosts multiple domains, it looks for the url record at the server.

    Plesk forwarding does not work because the url is being handled by Plesk forwarding and the target url can't handle the url. So I do not have an entry for the url I want to forward in Plesk.

    If you use CNAME record and url to forward, then the url is being handled by the dns setting and Plesk still isn't letting the targeted url handle that url. It just accepts the forward and resolves to the main WP site.

    If you us A record and IP address to forward, then, since there is no record in Plesk, it resolves to the url that is set as primary. Ahha!

    So the only way to make this work with Plesk is to either have a dedicated IP or set your main WP site to the Primary url.

    I hope this makes sense and helps anyone else using Plesk.

    Robert

  11. tonyzeoli
    Member
    Posted 3 years ago #

    Hi everyone:

    Now I have an issue with Plesk myself. It is not regarding my production environment, which is set up on a domain with the main domain being reesefelts.org.

    In Plesk, I have set up
    1. reesefelts.org/
    2. reesefelts.org/reesenews/, which resolves to reesenews.org, and 3. reesefelts.org/carolinaconnection/, which resolves to carolinaconnection.org.

    Here is my issue in Plesk.

    I need to create dev.reesefelts.org, as well as the aforementioned sites all for "dev."

    I will walk through the steps.

    1. In Plesk, I have created a subdomain: dev.reesefelts.org.
    2. I installed WPMU.
    3. I set the A Record to point to the IP address
    4. This works for dev.reesefelts.org perfectly
    5. I tried to create a CNAME to point:
    - dev.reesenews.org
    - dev.carolinaconnection.org
    However, since MediaTemple only offers an IP address and not a server name for Plesk (ex. s111222333.mediatemple.net), I cannot set a CNAME.
    6. I create an A Record at GoDaddy and Network Solutions for the dev.reesenews.org and dev.carolinaconnection.org domains pointing to the IP address.
    7. I click on Backend in WPMU for blog ID 2 and blog ID 3 and they resolve to reesefelts.org, and not reesefelts.org/reesenews/ or reesefelts.org/carolinaconnection
    8. I went into EDIT and checked the path of both sites, as well as checked the SITE URL. Even if I set the SITE URL to dev.reesenews.org, it still resolves at reesefelts.org.
    9. I check the domain mapping database tables and all the wp-options tables for /, 2, and 3, and don't see anything specifically wrong.

    The only thing I can think of, is that the DNS settings at GoDaddy still point to their domaincontrol entries, and not mediatemple.

    Even though I have an A Record for dev.reesenews.org, should I change the DNS settings to point to MediaTemple?

  12. mayday
    Member
    Posted 3 years ago #

    With the WPMU you have to choose whether to use subdomains or subfolders. You can not have both. Also, for WPMU to work with Plesk there can be only one WPMU site for each IP address. You must set the "default" domain to your WPMU domain: in Plesk by going to Server, IP Addresses and clicking on the actual number link in the Hosting column. Choose the default domain.
    This sounds like you might have to change your production environment somewhat. Another pointer is that additional IP addresses from MT are only $1 per month. If I am reading you right, this could let you use a second IP for dev.

    Hope this helps! You helped me greatly!
    Robert

  13. Also, for WPMU to work with Plesk there can be only one WPMU site for each IP address.

    Only if you're using wildcard subdomains. And only on some hosts.

  14. dasnich
    Member
    Posted 2 years ago #

    I too am using Media Temple, but I am on the Grid Service. I am having trouble getting the domain mapping plugin to function appropriately.

    1) I setup my primary domain and site, http://www.2020HomeSearch.com, setup the WPMU, and have successfully created sub domains. Test subdomain is bob.2020HomeSearch.com.
    2) I added and purchased several new domain names and they were added to my MT account and were assigned to my main domain grid service.
    3) I installed the Domain Mapping Plugin and entered my IP address on the network configuration and selected the options specified at http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/. I also followed this tutorial to the T several times...
    4) When I go to my site dashboard for bob.2020HomeSearch.com and I assign it one of my owned domains. NewDomain.com, the site disappears and any attempt to access the site leads to a page that just says Forbidden. I can no longer even access bob.2020homesearch.com or it's dashboard. I actually have to go back to the network admin and delete the domain mapping before I can get back in...

    Any help here or insight would be extremely appreciated.

    Kindest Regards,

    Nicholas

  15. tonyzeoli
    Member
    Posted 2 years ago #

    @dasnich On MediaTemple shared hosting, I believe what you have to do is create "symlinks."

    This involves:

    1. Adding each domain you control to the MediaTemple DNS service. You have to register all your domains in the MediaTemple so that each domain has its own DNS Zone entry.

    2. The above will create a folder for each domain on your shared account. You want to "symlink" each folder with your primary folder. Once you create the symlinks, you then delete the folders for each domain, because you no longer need them. Symlinks basically field the request from apache and send them to the primary folder.

    This will get you to where you need to be.

    Here is the article on MediaTemple with instructions on how to create the symlinks.

    http://kb.mediatemple.net/questions/63/Creating+symlinks+to+redirect+your+site

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic