WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
Endless loop after remote login (8 posts)

  1. Corey McKrill
    Member
    Posted 1 year ago #

    Here's the setup:
    Subdirectory multisite installation (3.4.1) for which the primary domain is a subdomain (staging.mydomain.com). Additional sites have other subdomains mapped to them, so staging.mydomain.com/othersite = othersite.mydomain.com. The "More Privacy Options" plugin is being used to restrict access to the additional sites to only logged-in users. The Remote Login option is turned on so every user will be sent to staging.mydomain.com to log in before redirecting to the site they are attempting to access.

    Here's the problem:
    With Remote Login turned on, a user attempting to access othersite.mydomain.com gets sent to staging.mydomain.com/wp-login.php. After logging in, the form attempts to send them to othersite.mydomain.com/wp-login.php?redirect_to=%2F. An endless loop starts where the browser alternates connections between staging.mydomain.com and othersite.mydomain.com while the page sits blank.

    - This doesn't happen with Remote Login turned off, but in this case, we want it turned on so that all logins go through the same domain.
    - Deleting cookies doesn't fix the problem.

    I'm at a loss for what to try next, so troubleshooting suggestions are appreciated.

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Check for script errors on your site.

  3. Corey McKrill
    Member
    Posted 1 year ago #

    Hi Ron, thanks for replying. Neither Firebug nor Chrome is showing any script errors on site pages. When it gets to the endless loop, the console keeps getting reset before it shows anything, so it's hard to tell there ...

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    If you turn the privacy off does that redirect loop go away?

  5. Corey McKrill
    Member
    Posted 1 year ago #

    After upgrading WordPress and BuddyPress to their latest versions, the endless loop problem seems to have gone away. However, remote login is still not working correctly, and it appears to be due to the interaction between domain mapping and the More Privacy Options plugin, as suggested above. Specifically, both plugins do a lot of redirection, so my guess is that there's a conflict somewhere. Now when I log in, with Remote Login turned on and Privacy set to Network Users only, it takes me to /wp-admin instead of the URL I started on, and any attempt to go to a page on the front end redirects back to /wp-admin.

    I realize that throwing a second plugin into the mix may take this issue outside the scope of troubleshooting the domain mapping, but I'm curious if anyone else who has used the combination of WordPress MU Domain Mapping and More Privacy Options has run into a similar issue...

  6. Jasonheffner
    Member
    Posted 1 year ago #

    I am using WordPress MU Domain Mapping with WP 3.4.2 and BuddyPress. I've also added FORCE_SSL_ADMIN to the multi-site install, but have this limited to only apply to the main site and none of the mapped domains. I am seeing the looping issue as well when I try and enable remote login and login to the mapped domain. Have you been able to narrow down the issue?

    I'm going to start diagnosing and trying to figure out how to get this working properly.

  7. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

  8. Jasonheffner
    Member
    Posted 1 year ago #

    @Ron Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic