WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
Domain Mapping missing from subdomains (11 posts)

  1. doggiedaddy1
    Member
    Posted 1 year ago #

    I have 3 installs for WordPress Multisite on Hostgator Linux hosting. All three were set up and running fine with this plugin until one of my assistants and/or support from Hostgator moved the wrong wp-config.php files into the wrong installs. The databases and redirects became polluted. I have since fixed this and gone into the databases to correct the erroneous redirects that were created, however the Domain Mapping is missing from the Tools tab of the subdomains. It is in Network as it should be, but not in the subdomains. Doesn't matter whether or not I check the box in settings under Network, all stays the same. Suggestions? Is this in the database or in the config files somewhere?
    Thanks

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    The only thing is that checkbox in the settings panel. Do you have it network activated?

  3. doggiedaddy1
    Member
    Posted 1 year ago #

    Yes, I've tried changing saving, changing back. No avail. Must be something else to check. It is network activated and appears under the network tab.

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Check you wp-config to see where the lines of code for DM were added.

  5. doggiedaddy1
    Member
    Posted 1 year ago #

    Assume you are referring to Sunrise.php
    It is the last line of code before "That's all, stop editing! Happy blogging!

  6. gaialabs
    Member
    Posted 1 year ago #

    I just found out the problem for this issue.

    You have to activate the plugin within *all* *subdomains*, not only in the network admin dashboard.

  7. doggiedaddy1
    Member
    Posted 1 year ago #

    Where do I do that?

  8. gaialabs
    Member
    Posted 1 year ago #

    Well, apparently the solution is different that what I did :-)

    You can simply go under the network admin page, go under Plugins and from there find the "WordPress MU Domain Mapping" plugin and click on "Network activate". And it will be activated for your whole network.

    Kind regards

  9. doggiedaddy1
    Member
    Posted 1 year ago #

    It is and has been network activated, hence the problem.

  10. gaialabs
    Member
    Posted 1 year ago #

    Indeed. It seems there is something wrong or a bug with this because when it was not network activated I was able to activate it in each subdomains and then I activated the plugin for the whole network and it worked.

  11. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    There have been no substantial changes to the plugin since WP 3.1. The issue you are having is not a bug but something about how your configuration was restored.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.