WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Importer
Media an posts import but media is not attached and urls dont change (5 posts)

  1. charliebrimm
    Member
    Posted 1 year ago #

    I've tried this several times on a blog that only has 107 posts. The importer finishes sometimes after hitting refresh after a stall and says all done.

    I have my posts, users, cats, media BUT the media is not attached to the posts and the links to images inside the posts links back to the old domain.

    The import file is only 836k. The size of the images is 307mb. I have split the file but the images are not attached and only some posts have the proper links.

    If I import media that corresponds to a post in the same file such as grabbing the first 20 media from the xml and deleting the rest and then cutting out all posts except for those that are parents to the aboe media everything works. This is a painful and laborious process as I will have to do this 15 more times for blogs that I am moving.

    Any ideas?

    http://wordpress.org/extend/plugins/wordpress-importer/

  2. prionkor
    Member
    Posted 1 year ago #

    In my case media isn't imported although i checked the download and attach media. I am in subdomain multisite and importing one site to another.

    Please help!

  3. brandt-net
    Member
    Posted 1 year ago #

    On my import the media isn't imported although

  4. topdownjimmy
    Member
    Posted 1 year ago #

    I've solved this problem with these two plugins:

    http://wordpress.org/extend/plugins/search-and-replace/
    http://wordpress.org/extend/plugins/add-linked-images-to-gallery-v01/

    But this functionality SHOULD be part of the WordPress Importer plugin natively.

  5. prionkor
    Member
    Posted 1 year ago #

    @topdownjimmy: agreed!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic