WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] [Plugin: WordPress HTTPS] [Wordpress HTTPS Plugin] Shared SSL Setting -- Causing Login Redirect (7 posts)

  1. matthewjamesshaw
    Member
    Posted 3 years ago #

    I installed WordPress HTTPS a few hours ago, edited the plugin to take advantage of my shared SSL from the host.

    Everything ran super slow for a little while, now I can't log in at all. It gives me a redirect loop. "https://www.speakupmag.org/~speakupm/wp-login.php?redirect_to=http://www.speakupmag.org/wp-admin/&reauth=1"

    I've tried everything I can think of. Deleted the plugin via FTP. Delete records created by the plugin in PHPadmin. Even temporarily disabled the entire plugin folder.

    Nothing. I'm at a loss.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. SAHIL
    Member
    Posted 3 years ago #

    check the wp-config file..
    if there are these two values edit remove them and save the file..

    define('FORCE_SSL_LOGIN', true);
    define('FORCE_SSL_ADMIN', true);

    then u might be able to login normally (using http)

  3. matthewjamesshaw
    Member
    Posted 3 years ago #

    I got the fix from my hosts tech support.

    They told me which database records to change: siteurl and home.

    Thanks for the response!

  4. matthewjamesshaw
    Member
    Posted 3 years ago #

    I got the fix from my hosts tech support.

    They told me which database records to change: siteurl and home.

    Thanks for the response!

  5. SAHIL
    Member
    Posted 3 years ago #

    glad u got it fixed.. can u please explain in more detail what u did?

    eg. like u change the values of records siteurl and home from what to what...

    because many people using shared ssl are having problems.. more explanation might help them....

  6. SimpleSEOGroup
    Member
    Posted 2 years ago #

    I'm having this same issue and don't have a clue where to start working on it-- Matthew do you think you could share your solution so I can give it a try? Thanks!!

  7. SimpleSEOGroup
    Member
    Posted 2 years ago #

    I love when I do this--solve my own problem.

    Here are the steps to solving this issue but be careful as it involves editing the actual SQL database.

    Log in to your host's website and go to phpMyAdmin (with some hosts you may have to ask them to do this for you).

    You're going to click on the database for your wordpress install, then go to wp-options

    From here you are looking for two different rows, one called siteurl and one called home. Once you find them hit edit and make sure your site url is correct (in this case mine contained HTTTPS instead of HTTP which appears to have caused this issue). Fix the siteurl and home, hit save, and you are hopefully good to go!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic