WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] [Plugin: WordPress HTTPS] WordPress HTTPS breaks WordPress redirect to www (7 posts)

  1. hippypink
    Member
    Posted 3 years ago #

    As you know, WordPress autoredirects to the domain defined in the General Settings.

    E.g. If I set my site to http://www.example.com when I setup wordpress, then whenever someone types http://example.com, it auto redirects to http://www.example.com

    With WordPress HTTPS plugin, this is no longer the case. It no longer redirects like it should.

    I have tried just about every setting, as well as disabling all other plugins to be sure.

    I know I could use a custom rule in my htaccess, but that defeats the purpose a bit, and easier to accidently break the site (conflict with wordpress settings). The need to auto redirect is pretty important for many search robots.

    If needed, I could donate a bit even to get this fixed asap.

  2. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    This is disabled in an attempt to minimize the redirect loop issues that are pretty common with WordPress and SSL.

    In the next version of WordPress HTTPS (1.8), this functionality is only disabled if you are using Shared SSL, as the redirect issues are most common there.

    I'll be pushing out version 1.8 today, and I will update this topic when I do. Then, you can give it a try and let me know if it fixes your issue.

    Thanks for downloading! :)

  3. bryanb55
    Member
    Posted 3 years ago #

    Yup, I'm having the same problem. Was just going to post about this... I'll be waiting for the update also, please keep us posted!

  4. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    I just pushed out 1.8. You should see it within 15 minutes or so.

  5. bryanb55
    Member
    Posted 3 years ago #

    Just upgraded but it did not fix the problem. Is this only going to force www. ? my default URL leaves out the www. I need it to redirect all www.'s to my URL without www

    but I'm assuming it should be forcing the default URL format as set in wordpress? That doesn't seem to be happening.

    Thanks

  6. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    Well, that would be because I goofed on the update. Uno momento as I push out 1.8.1, lol.

  7. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    Okay, sorry about that guys. 1.8.1 just got pushed out so it should show up shortly. Let me know!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic