WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] [Plugin: WordPress HTTPS] This page is not redirecting properly (5 posts)

  1. jeremyb503
    Member
    Posted 3 years ago #

    Sir,

    I am using your plugin to make sure that the shopping cart pages (wp e-commerce) are redirected to secure url's. For some reason as soon as I activate the plugin and click the check boxes to make the cart pages secure it give me the endless loop. I have tried many combination of settings no luck.

    Any suggestions?

    Thanks!

  2. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    Hey Jeremy,

    I've had quite a few users report the same problem, but I can't reproduce it myself. I'm going to bring out a new version (1.7.1) here shortly that may fix the issue. If it does not, please reply to this topic and we'll dig deeper into the issue. I know it's affecting quite a few people, so I'd like to get it resolved.

  3. jeremyb503
    Member
    Posted 3 years ago #

    It is happening to me here: https://easyncoa.com/checkout-2/ and here http://easyncoa.com/noca-processing-file-upload/

    I could create you an account on our site if that would help.

    Thanks.

  4. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    Sure, I can test the new version on your site and see if it works.

    Just make sure that I'm able to edit plugins from within the WordPress admin panel (make the plugins folder writable) so that I can edit the plugin to see if I can fix the issue.

    You can send the details to me at mike[at]mvied[dot]com.

  5. Mvied
    Member
    Plugin Author

    Posted 3 years ago #

    The problem ended up being the hosting environment the WordPress installation was on.

    The server was not correctly reporting back that the connection was HTTPS, so it threw the plugin into a redirect loop. The same thing happened when uninstalling all plugins and forcing SSL on the admin panel, so the problem was with the host.

    If anyone else is having the redirect problem, it be because your host does not correctly show that the current page is HTTPS. If you think this is the case, start a support topic and I'll take a look at your site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic