WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] WordPress https ssl-proxy options-general.php was not found on this (10 posts)

  1. canoetom
    Member
    Posted 2 years ago #

    Hi,
    i installed a fresh WP in a subdirectory like:
    wordpress-url http://www.servername.net/foldername
    blog-url http://www.servername.net

    my .htaccess in root-directory:

    DirectoryIndex index.php
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    for index.php:
    require('./foldername/wp-blog-header.php');

    The plugin is configured like:
    ssl.webpack.de/www.servername.net (hosteurope)
    Force SSL Exclusively yes
    Force SSL Administration yes

    Basicely everything is working fine, login is redirected to the ssl-proy, website is working without ssl. Thats exactly what i wanted.
    Only Problem: if i try to change settings in option/general, i get the message: options-general.php was not found on this server.
    However, changes are accepted and everything else is working pretty fine. So, whats going wrong?

    Anyway, thank You for this great plugin!

    Greetings,
    Thomas

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Thomas,

    What is the URL of the page you receive that error on? Also, have you updated WordPress recently?

    Thanks,
    Mike

  3. canoetom
    Member
    Posted 2 years ago #

    Hi Mike
    https://ssl.webpack.de/www.myserver.net/foldername/wp-admin/options-general.php
    If i click on "save changes", i get:
    The requested URL /foldername/wp-admin/options-general.php was not found on this server.
    Its a fresh WP 3.3, no Update. I tryied several new installs, always the same Problem if i install in subdirectory and if i have your plugin activated.
    Installation in rootdirectory with your plugin works fine.
    Also installation in subdirectory without the plugin works fine.
    But i prefer installing in subdirectory.

    Thank you,
    Thomas

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Thomas,

    Okay, but what is the URL of the page that has the "The requested URL /foldername/wp-admin/options-general.php was not found on this server." error on it?

    Thanks,
    Mike

  5. canoetom
    Member
    Posted 2 years ago #

    Hi Mike,
    https://ssl.webpack.de/foldername/wp-admin/options-general.php?settings-updated=true

    I hope this is what you asked for.

    Thnaks,
    Thomas

  6. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Thomas,

    What is your SSL Host set to? Is it something like "ssl.webpack.de/www.myserver.net" ?

    Thanks,
    Mike

  7. canoetom
    Member
    Posted 2 years ago #

    Exactly. ssl.webpack.de/www.cello-berlin.net

    Thanks,
    Thomas

  8. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Thomas,

    I'm really not sure what's happening. Do you mind if I login and take a look? I just need an admin account that can edit plugins. My email is mike[at]mvied[dot]com.

    Thanks,
    Mike

  9. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Thomas,

    I checked out your site and it seems to be a compatibility issue with WordPress and your Shared SSL server. I logged into the site, then disabled the plugin, went to Settings -> General, hit "Save Changes" and received the same error.

    It's because the URL path is being reported as '/foldername/wp-admin/options-general.php' rather than '/www.myserver.net/foldername/wp-admin/options-general.php' when using the Shared SSL. After submitting the form, it tries to redirect you to the path that you came from (which is reported incorrectly) and sends you to the wrong place.

    Luckily, I can fix it. I've hotfixed it on your site and will get a fix into the next release.

    Thanks,
    Mike

  10. canoetom
    Member
    Posted 2 years ago #

    Hey Mike,
    great work! Now everything works fine :-)

    Only one thing i dont understand:
    >I logged into the site, then disabled the plugin, went to Settings -> >General, hit "Save Changes" and received the same error.

    To check this, i did again a fresh wp-setup, installed in a subdirectory without your plugin. No errors at all!

    Anyway, its working fine now with your hotfix.
    Thank you so much for your help! (You received a donation for that)

    Greetings from Berlin, Germany

    Thomas

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic