WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
WordPress HTTPS gives misconfiguration error. (8 posts)

  1. soonermike
    Member
    Posted 1 year ago #

    I am running a site on a Logic server. They have set up my site to use their shared certificate. They say that my main URL should be recognized by the certificate.

    I activate HTTPS and tic the "secure post" box on the page. When I try to open that page, I get a warning that states, "This is probably no the site you are looking for! You attempted to reach (my main URL), but instead instead you actually reached a server identifying itself as (a completely different URL with the logix name in it). This may be caused by a misconfiguration on the server or by something more serious. You should not proceed" and then I have the option of "proceed anyway" or "back to safety."

    If I click "proceed anyway," the https:// in teh URL is marked out in red, and the error message says, "Not Found - The requested URL (page URL minus the main .com part) was not found on this server."

    If I go into the plugin and tell it to use the URL it says I'm actually targeting, the error says, "Not Found - The requested URL (main URL that is not mine, but the certificate, plus the rest of the page URL) was not found on this server."

    Is this a misconfig by the host, or am I doing something wrong?

    http://wordpress.org/extend/plugins/wordpress-https/

  2. soonermike
    Member
    Posted 1 year ago #

    Sorry, that should say Logix server, not Logic.

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    If you're using their Shared SSL certificate using HTTPS on your domain will not work. You need to enter the shared SSL host information into the SSL Host field in the WordPress HTTPS Settings.

  4. soonermike
    Member
    Posted 1 year ago #

    Okay, so I put in the shared host info and set Proxy to yes. Still getting first error message I mentioned above. Grabbed the debug from console:

    [BEGIN WordPress HTTPS Debug Log]
    http://www.myURL.com/:268

    Version: 3.1.2
    http://www.myURL.com/:269

    HTTP URL: http://www.myURL.com/
    http://www.myURL.com/:270

    HTTPS URL: https://shared certificate URL.net
    http://www.myURL.com/:271

    SSL: No
    http://www.myURL.com/:272

    Diff Host: Yes
    http://www.myURL.com/:273

    Subdomain: Yes
    http://www.myURL.com/:274

    Proxy: Yes
    http://www.myURL.com/:275

    Secure External URLs: [ ]
    http://www.myURL.com/:276

    Unsecure External URLs: [ ]
    http://www.myURL.com/:277

    [END WordPress HTTPS Debug Log]
    http://www.myURL.com/:278

    Uncaught TypeError: Cannot read property 'length' of undefined
    chrome-extension://lineaegmeiendabencimakjagjojcegk/content.js:81

    allow right click initializing for http://www.myURL.com/
    chrome-extension://hompjdfbfmmmgflfjdlnkohcplmboaeo/rightclick.js:1

    allow right click processing http://www.myURL.com/

    Not sure where to go from here. maybe I need to put in a different port? Thanks for responding so quickly before. :)

  5. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    What page were you on when you got the debug log? Are you sure you need to enable the Proxy feature? Did you try Auto before that?

    Just email me the links if you don't want to post them. It's a lot easier to just see what's going on. My email is mike[at]mvied[dot]com.

  6. soonermike
    Member
    Posted 1 year ago #

    Email sent.

  7. soonermike
    Member
    Posted 1 year ago #

    Maybe a breakthrough? Downloaded and installed the developmental version of the plugin. Used the host path recommended by the hosting company. Under domain mapping, set the unsecured URL of the page I want to secure to go to sec.templar.logixcom.net/limousinworld/subscriptions/order-limousin-world-online and now the certificate sticks, but I get an error saying it can't find index.php. Is this progress?

  8. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    In this thread a user mentions adding ErrorDocument 404 /index.php to your .htaccess. Give that a shot. I've never had any experience with dealing with these Shared SSL's, so I'm just guessing.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags