WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
When I secure a page using the HTTPS Plugin it changes my theme (9 posts)

  1. dookied2
    Member
    Posted 1 year ago #

    When I secure a page on my site, the theme on that page changes.

    How do I keep that from happening?

    This is my first attempt at using SSL on a WP site, so I'm sorry if this is a stupid question/issue. :)

    Thanks!

    My url:

    http://www.thecupboardrestaurant.com/employment/ (currently has correct theme and is not secure)

    http://wordpress.org/extend/plugins/wordpress-https/

  2. jfacemyer
    Member
    Posted 1 year ago #

    How does it change? Do you mean that it uses a different theme, or that the theme is broken?

    It's certainly not a stupid question - SSL issues are difficult, and as far as I can tell, this is the only plugin which makes it "easy" to do SSL in a comprehensive manner with many plugins. Don't give up! :)

  3. dookied2
    Member
    Posted 1 year ago #

    jfacemyer,

    Thanks for your response...

    I'm currently using a child theme. When I secure a page on my site using the plugin, the theme on that page and that page only changes back to the primary theme. The rest of the site still has the child theme as it should. I'm sure it is because of something I'm doing wrong. :)

  4. jfacemyer
    Member
    Posted 1 year ago #

    Can you put up a hidden page and turn on ssl for it, then post it here?

    If that does the same thing, it might be easier to see what the problem is.

  5. jfacemyer
    Member
    Posted 1 year ago #

    Also, what browser(s) have you checked?

  6. dookied2
    Member
    Posted 1 year ago #

    Here is a test page where HTTPS is turned off and everything theme wise looks the way it should:

    http://www.thecupboardrestaurant.com/this-a-test-page-to-chk-https/

    Here is a page with HTTPS turned on. Note that it reverts to the parent theme, background, etc.:

    https://www.thecupboardrestaurant.com/this-a-test-page-to-chk-https2/

    Any assistance in getting this resolved would be greatly appreciated.

    Thanks!

  7. dookied2
    Member
    Posted 1 year ago #

    I usually use Chrome, but have looked at it in Firefox and I think IE 9 also... It doesn't appear to be a browser related issue.

  8. jfacemyer
    Member
    Posted 1 year ago #

    I was trying to figure out your site this morning, but after a couple of refreshes, now nothing will refresh :(

  9. jfacemyer
    Member
    Posted 1 year ago #

    Ok - for some reason the https is truncating your css:

    <style id="custom-background-css" type="text/css">
    body.custom-background { background-image: url('https://www.thecupboardrestaurant.com/wp-content/uploads/2012/04/tableclothMEDSHADOW.png'); background-repeat: no-repeat; background-position: top center; background-attachment: fixed; }
    </style>

    to:

    <style id="custom-background-css" type="text/css">
    body.custom-background { background-image: url('https://www.thecupboardrestaurant.com/wp-content/uploads/2012/04/tableclothMEDSHADOW.png'; background-repeat: no-repeat; background-position: top center; background-attachment: fixed; }
    </style>

    The only difference is a missing ")" at the end of the image url.

    I've had trouble with the current version truncating urls, but not the same thing, though it could be related.

    Try downgrading to 3.1.1, see if that helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.