WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
Using 3.0.3 and now everything is broken!! (11 posts)

  1. jrotella
    Member
    Posted 1 year ago #

    Site was working great - only checkout pages were HTTPS.

    Now, when you click "Checkout", you get an error about too many re-directs and the page won't come up (Error 310 in Chrome).

    Force SSL Exclusively IS NOT checked
    Secure post IS checked on the checkout page I created
    There's a new page in the site now, Mijreh Secure Checkout where the Secure Post box IS NOT checked. It says it's Privately Published (no idea what that is). and it has content in the body (but doesn't match my Checkout page content).

    If Force SSL Exclusively is checked, I can't get in to the site at all.

    So, now no one can check out of my store :( It was working fine as of Friday (that was the last order I got).

    Can anyone help me sort this out? I'm not a WP developer and I'm in way over my head with this one.

    Thank you!

    [ Signature moderated. ]

    http://wordpress.org/extend/plugins/wordpress-https/

  2. jrotella
    Member
    Posted 1 year ago #

    I unchecked "Secure Post" on my checkout page, so now folks can checkout, but nothing is secure :(

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Only thing I know to cause this is an odd server configuration, or if you have Better WP Security installed, it can cause this as well. Does it happen on any page you secure?

  4. WendellH
    Member
    Posted 1 year ago #

    I'm having the same problem: https://plso.org/news-events/chapter-events/rogue-river-floodplain-workshop-registration/

    I don't have Better WP Security installed, nor other plugins regarding security aside from WordPress HTTPS (SSL).

    The page is a Gravity form with the Authorize.net add-on for Gravity. If I uncheck the secure page setting, the page loads fine.

    Following another thread, I removed all the "wordpress-https" references from the database, too.

    Thanks for any help you can provide.

  5. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    It's possible the cart you're using provides some kind of setting for using SSL. If their setting is turned off and you're securing the page with my plugin, it's possible there is a conflict.

  6. WendellH
    Member
    Posted 1 year ago #

    I am using Paid Memberships Pro and SSL is on. I also have Gravity Forms with the Authorize.net addon with SSL on. I noticed that if I remove WordPress HTTPS directory from wp-content/plugins, the 310 error goes away. However, that is obviously a problem.

    I also tried leaving WordPress HTTPS activated and deactivated Gravity Forms along with the addons, and the problem persists.

    This morning, I upgraded WordPress HTTPS to 3.0.4 in hopes that it would help matters but it ended up giving me a 310 error on the entire admin area.

    I would happily give you admin access to the site if you'd like to troubleshoot it to see what may be the problem.

  7. WendellH
    Member
    Posted 1 year ago #

    You can reach me at [ email redacted ]

  8. WendellH
    Member
    Posted 1 year ago #

    Update: I have the same problem with the 310 error on any site that I upgrade to 3.0.4.

  9. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I emailed you a few minutes ago Wendel. I'm interested to see what's going on.

  10. neoncs
    Member
    Posted 1 year ago #

    Had same Problem went into HTTPS setting and clicked Reset then saved changes. Now working.

  11. WendellH
    Member
    Posted 1 year ago #

    I responded with access info, but haven't heard back yet.

    I would try the reset settings trick, but I get the lovely 310 error when activating the plugin, so I can't get to the settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic