WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
SSL login not working (2 posts)

  1. Chad Warner
    Member
    Posted 2 years ago #

    I only need the login to be encrypted; not the entire admin area. I installed this plugin and entered my shared SSL URL (https://secure.hostmonster.com/~xxxxx) in the plugin. I then added define('FORCE_SSL_LOGIN', true); to wp-config. When I open test.domain.com/wp-login.php, the form action is still http://test.domain.com/wp-login.php, not https. If I manually enter https://test.domain.com/wp-login.php, the form action is still http.

    If I remove define('FORCE_SSL_LOGIN', true); from wp-config but leave the plugin enabled, the form action is http://test.domain.com/wp-login.php. If I manually enter https://test.domain.com/wp-login.php, the form action is still http.

    For what it's worth, If I disable the plugin and simply leave define('FORCE_SSL_LOGIN', true);, the form action is https, but after submitting I get redirected to https://test.domain.com/~xxxxx/test/wp-login.php, which doesn't go anywhere.

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    I just pushed out version 3.0 which may or may not fix the issues you were having. Please try updating and let me know if you need any help.

    Sorry for the late response. I have not had time to support the plugin for a while now. Since I just pushed out 3.0, I'll be keeping an eye on the support forums to fix any bugs that arise.

    Thanks,
    Mike

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic