WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] Shared SSL & non-default Permalinks: Let's solve this! (16 posts)

  1. Bozz
    Member
    Posted 1 year ago #

    Hi everyone--

    This plugin is awesome, and one issue holding us back from using it more is that at least with shared SSL situations (ex: bluehost, hostgator), one has to turn off pretty permalinks and instead use the default (ex: yoursite.com/?p=224).

    So far the only hunch is to add to your .htaccess:
    ErrorDocument 404 /index.php

    But this doesn't seem to work for me, at least not with a blog installed into a subdirectory. As I understand it, WP isn't processing the permalink structure because it's not the default installation URL. The ? modifier seems to get around this.

    Interestingly, if I use my shared ssl URL structure and only keep it the root directory of the blog, (ex: https://secure.bluehost.com/~username/dev/cms/ ) the page template loads but with a wordpress-processed 404 error message.

    If I try to go one level further (https://secure.bluehost.com/~username/dev/cms/apage) then I get a real server 404

    Anyway, I figure there are hundreds of us who are effected by this and it would be great for us to solve this problem collectively so we can all benefit from not having to turn on global default permalinks to get it to work with shared SSL.

    Would really appreciate hearing from others who are trying to work around this. Thanks!

    http://wordpress.org/extend/plugins/wordpress-https/

  2. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    To my knowledge, there is no way around this. The proxy sitting in front of the server hosting WordPress is not properly passing the Request URI so WordPress doesn't know where to send the user (it can't even pull up the front page). Unfortunately, this is caused by a proxy not being configured correctly, but sometimes it is intentional by the hosting company because they do not want you using the Shared SSL certificate with WordPress or anything like that.

    That's what I've learned from talking to users of my plugin that have run into this issue.

  3. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I do have a theory that if I can somehow get WordPress to strip off the extra Shared SSL path information (/~username) before it tries to query the current page, that it would cause the URL's to be looked up by their correct path, and it would work. Just a theory.

  4. Bozz
    Member
    Posted 1 year ago #

    Thanks for the insight!

    Is there any specific behavior or events you are picking up that indicates an improper proxy setting?

    If we can't get the proxy to play nice, can we help WordPress anticipate these requests and serve up the proper information, perhaps through .htaccess ?

  5. Bozz
    Member
    Posted 1 year ago #

    Is it possible to make these configuration options conditional on https? Maybe a conditional wp-config.php?

    define('WP_SITEURL', 'https://secure.bluehost.com/~USERNANAME/BLOG_DIRECTORY');
    
    define('WP_CONTENT_URL', 'http://www.site.com/BLOG_DIRECTORY/wp-content');

    Thanks!

  6. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    This should be fixed in the latest release. I found the filter for WordPress' rewrite rules and that allowed me to add a filter including the extra path information, causing the pages to now be found.

  7. Bozz
    Member
    Posted 1 year ago #

    Great news! I'll try it out, thank you!!

  8. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    Try the development version if you're going to be trying soon.

  9. hurucheng1212
    Member
    Posted 1 year ago #

    Bozz
    Member
    Posted 4 days ago #

    Great news! I'll try it out, thank you!!

    Mvied
    Member
    Posted 4 days ago #

    Try the development version if you're going to be trying soon.

    R

  10. phetefirst
    Member
    Posted 1 year ago #

    Thanks for the great plugin, though I am having the same issues (bluehost shared ssl, 404s on any pages with forced ssl). I tried the development version you recently posted, this did not solve the issue. What am I doing wrong? ;)

  11. Mvied
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure if the plugin has been tested with Bluehost's Shared SSL yet.

    If you could give me admin access and FTP access to a WordPress install on your server and the Shared SSL URL, I may be able to get the plugin to work on Bluehost. Some Shared SSL's will never work.

  12. phetefirst
    Member
    Posted 1 year ago #

    Thank you, I just sent you an email.

  13. colewebdev
    Member
    Posted 1 year ago #

    I just tried again with the development version and am still getting a 404 on HostGator.

    I'm assuming the "domain mapping" feature is where we configure this, although I didn't see any documentation so I may have the values wrong.

    Can you explain this new feature so we can test?

    My secure URL format is the following:

    https://secure000.websitewelcome.com/~username/

  14. sanjayidhatiya
    Member
    Posted 1 year ago #

    i had Same issue.

    Some Pages Of wordpress does not work with ssl with permalinks on.

    but after reading many posts and trying to be solved i found the solution.

    just add your page name means permalinks url to "URL Filter".

    And it's Work For me

    thanks for such a great Plugin.

  15. Chad Warner
    Member
    Posted 1 year ago #

    I just tested the dev version with Hostmonster (owned by Bluehost, with the same shared SSL configuration) and still get redirect errors and 404 pages when trying to secure my login. All I want to do is use my shared SSL to secure my login form.

    I'd be happy to help troubleshoot. Just let me know what details you need.

  16. Chad Warner
    Member
    Posted 1 year ago #

    Has there been any progress on this (specifically, using shared SSL from Bluehost or Hostmonster)?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic